Bug 65361 - Omni-foomatic contains zero-byte XML files
Omni-foomatic contains zero-byte XML files
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: Omni (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-22 15:02 EDT by Need Real Name
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-23 05:24:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-05-22 15:02:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020412
Debian/0.9.9-6

Description of problem:
The "cd Foomatic ; make run ; cd .." run in the latest Omni-0.6.1-1 would search
the system, not the build dir, for the printer files.  Assuming no printers were
found, zero-byte XML files were generated.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
I think this problem would manifest itself when Omni is built (perhaps with no
Omni installed on the system at the time?)  A quick check on rpmfind would show
that builds for all architecture, the XML files are zero-byte.

Additional info:

In the Omni.spec provided by upstream Omni developers, the Omni-foomatic  XML
files are generated during the "make install" stage.  You may consider using
their "make install" instead.  However, I realize that dumping everything in
/usr/lib/Omni/{bin,lib} may not quite fit the FHS.  And perhaps you didn't want
the "XML generation" stage to be run during "make install".  Anyhow, whatever
way you would like to fix it is up to you.  :-)

Last but not least, thank you very much for your hard work in improving the Red
Hat printing system.  What, with all the GhostScript + Gimp-Print + HPIJS + Omni
+ CUPS + Foomatic and friends, it is indeed really hard to sort everything out.
 Thank you for making all these work.  :-)

Cheers,

Anthony
Comment 1 Need Real Name 2002-05-22 15:19:19 EDT
BTW, also related to Omni.spec (Omni-0.6.1-1):

 1. Kyocera printer support was not installed.

 2. No executables were installed.  (e.g. /usr/lib/Omni/bin/* in the upstream
RPM)  I don't know if you want to add them or not for Red Hat, and whether you
want to keep them in /usr/lib/Omni/bin/ or move them to /usr/bin.  :-)

Cheers,

Anthony
Comment 2 Tim Waugh 2002-05-23 05:24:31 EDT
Thanks for spotting this. 
 
The provided 'make install' does all sorts of things that aren't appropriate  
for RPM packaging, but I've added Kyocera to our spec file to get that 
installed properly. 
 
I'm investigating why zero-sized files turned up; this happened on the build 
machine but not on the machine I packaged it up on first of all. 
 
[And yes, it is really hard to sort everything out.. :-) ]
Comment 3 Tim Waugh 2002-05-28 13:36:44 EDT
I'm pretty sure this was caused by a transient bug in libstdc++.  Fixed 
package is Omni-0.6.1-2.

Note You need to log in before you can comment on or make changes to this bug.