Bug 653674 - Fails to create debug build of Qt projects on mingw
Fails to create debug build of Qt projects on mingw
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: qt (Show other bugs)
14
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Patch, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-15 17:19 EST by Ivan Romanov
Modified: 2013-10-03 20:46 EDT (History)
12 users (show)

See Also:
Fixed In Version: qt-4.7.1-3.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-28 15:43:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix QTBUG-14467 (1.56 KB, patch)
2010-11-15 17:19 EST, Ivan Romanov
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Qt Bug Tracker QTBUG-14467 None None None Never

  None (edit)
Description Ivan Romanov 2010-11-15 17:19:42 EST
Created attachment 460681 [details]
Patch to fix QTBUG-14467

Description of problem:
See upstream bug http://bugreports.qt.nokia.com/browse/QTBUG-14467.
They silent for one month. While they thinking I make patch to fix it. See in attachments.
Comment 1 Kevin Kofler 2010-11-23 14:43:03 EST
So, my understanding is that the Fedora MinGW maintainers would like us to apply this patch to our qt package, is that correct?

If it is so, since it shouldn't affect anybody else, I'm OK with applying that patch to our Qt packaging. I'd prefer this to get sorted out upstream, but I'm OK with the patch if the MinGW folks are convinced it's right.

(I personally have some reservations about a variable named $${QT_LIBINFIX} being made a postfix though. MinGW folks: are you sure this makes sense?)
Comment 2 Erik van Pienbroek 2010-11-23 15:01:38 EST
> So, my understanding is that the Fedora MinGW maintainers would like us to
> apply this patch to our qt package, is that correct?

That's correct

> If it is so, since it shouldn't affect anybody else, I'm OK with applying that
> patch to our Qt packaging. I'd prefer this to get sorted out upstream, but I'm
> OK with the patch if the MinGW folks are convinced it's right.
> 
> (I personally have some reservations about a variable named $${QT_LIBINFIX}
> being made a postfix though. MinGW folks: are you sure this makes sense?)

We've asked upstream in the mentioned bugreport what the correct behaviour should be (should the suffix be 'd4' of '4d'? where does the '4' come from?). Unfortunately we haven't seen any response to that question so our best guess is to work around it in the qmake mkspecs files for now until upstream provides more information.

The win32 binaries provided by upstream all use the suffix 'd4' as well so our packaging looks okay from that point of view
Comment 3 Kevin Kofler 2010-11-23 15:13:24 EST
I guess that's enough justification for me, let's apply the patch. What do the other Qt comaintainers think?
Comment 4 Rex Dieter 2010-11-23 15:28:01 EST
fine with me, let's do it.
Comment 5 Jaroslav Reznik 2010-11-24 10:21:58 EST
+1
Comment 6 Fedora Update System 2010-11-24 12:03:06 EST
qt-4.7.1-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/qt-4.7.1-3.fc14
Comment 7 Fedora Update System 2010-11-25 20:10:28 EST
qt-4.7.1-3.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update qt'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/qt-4.7.1-3.fc14
Comment 8 Ivan Romanov 2010-11-26 05:58:15 EST
I installed qt-4.7.1-3.fc14.x86_64. I do test and it's now work. Thank!
Comment 9 Fedora Update System 2010-11-28 15:42:55 EST
qt-4.7.1-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 10 Red Hat Bugzilla 2013-10-03 20:19:33 EDT
Removing external tracker bug with the id '14467' as it is not valid for this tracker

Note You need to log in before you can comment on or make changes to this bug.