Bug 653690 - indi_lx200autostar is missing which causes Kstars to hang in Telescope wizard
Summary: indi_lx200autostar is missing which causes Kstars to hang in Telescope wizard
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libindi
Version: 14
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Sergio Pascual
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-15 22:50 UTC by Frank Danapfel
Modified: 2010-12-12 20:06 UTC (History)
1 user (show)

Fixed In Version: libindi-0.6.2-2.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-12 20:06:00 UTC


Attachments (Terms of Use)

Description Frank Danapfel 2010-11-15 22:50:13 UTC
Description of problem:
I tried to set up Kstars and INDI on Fedora 14 to be able to control my Meade ETX125 telescope. Kstars is unable to set up the communication with the telescope because it is apparently looking for a "indi_lx200autostar" driver which does not exist. The only drivers for Meade telescopes available in the libindi package are "indi_lx200basic" and "indi_lx200generic":

-rwxr-xr-x.   1 root root       88608 21. Aug 13:38 indi_celestron_gps
-rwxr-xr-x.   1 root root       56816 21. Aug 13:38 indi_eval
-rwxr-xr-x.   1 root root       88248 21. Aug 13:38 indi_fli_ccd
-rwxr-xr-x.   1 root root       75872 21. Aug 13:38 indi_fli_pdf
-rwxr-xr-x.   1 root root       75584 21. Aug 13:38 indi_fli_wheel
-rwxr-xr-x.   1 root root       45992 21. Aug 13:38 indi_getprop
-rwxr-xr-x.   1 root root       84000 21. Aug 13:38 indi_intelliscope
-rwxr-xr-x.   1 root root       96216 21. Aug 13:38 indi_lx200basic
-rwxr-xr-x.   1 root root      194712 21. Aug 13:38 indi_lx200generic
-rwxr-xr-x.   1 root root      117056 21. Aug 13:38 indi_meade_lpi
-rwxr-xr-x.   1 root root       84384 21. Aug 13:38 indi_orion_atlas
-rwxr-xr-x.   1 root root       86120 21. Aug 13:38 indi_robofocus
-rwxr-xr-x.   1 root root      109336 21. Aug 13:38 indi_sbig_stv
-rwxr-xr-x.   1 root root       42248 21. Aug 13:38 indiserver
-rwxr-xr-x.   1 root root       44528 21. Aug 13:38 indi_setprop
-rwxr-xr-x.   1 root root       84000 21. Aug 13:38 indi_skycommander
-rwxr-xr-x.   1 root root       84568 21. Aug 13:38 indi_temma
-rwxr-xr-x.   1 root root       71568 21. Aug 13:38 indi_trutech_wheel
-rwxr-xr-x.   1 root root      115056 21. Aug 13:38 indi_v4l_generic
-rwxr-xr-x.   1 root root      119944 21. Aug 13:38 indi_v4l_philips


Version-Release number of selected component (if applicable):
libindi-0.6.2-1.fc14.x86_64
kdeedu-kstars-4.5.2-2.fc13.x86_64
kdeedu-kstars-libs-4.5.2-2.fc13.x86_64

How reproducible:
always

Steps to Reproduce:
1. start Kstars
2. try to set up telescope via "Telescope Wizard" in "Device" menu
3. click through screens, Kstars will hang when trying to connect to the telescope
  
Actual results:
Kstars hangs when trying to connect to telescope

Expected results:
Should be able to control telescope from Kstars

Additional info:
Here's the section from /usr/share/indi/drivers.xml which shows that there should be a indi_lx200autostar driver for my trelescope:
        <device label="ETX125" focal_length="1900" aperture="127">
                <driver name="LX200 Autostar">indi_lx200autostar</driver>
                <version>2.0</version>
        </device>

Comment 1 Sergio Pascual 2010-11-15 23:12:01 UTC
indi_lx200autostar seems to be a symlink to indi_lx200generic. I will research why the symlink is not created during install stage. As a workaround you can create the symlink yourself.

Comment 2 Frank Danapfel 2010-11-16 20:54:51 UTC
Ok, adding a symlink from /usr/bin/indi_lx200autostar to /usr/bin/indi_lx200generic fixed the issue for me.

I noticed that some other drivers (or symlinks) that are listed in /usr/share/indi/drivers.xml are missing as well, for example "indi_lx200gps", "indi_lx200classic" or "indi_lx200ap". Maybe those can be fixed in the next version of libindi as well (libindi 0.7.1 has just been released btw, maybe something to add in Fedora 15).

Comment 3 Fedora Update System 2010-11-26 00:09:01 UTC
libindi-0.6.2-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/libindi-0.6.2-2.fc14

Comment 4 Fedora Update System 2010-11-26 21:07:59 UTC
libindi-0.6.2-2.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update libindi'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/libindi-0.6.2-2.fc14

Comment 5 Frank Danapfel 2010-11-29 14:28:46 UTC
Just wanted to report that with the new package the links to indi_lx200autostar and the other lx200 related drivers are created correctly.

Thanks for fixing this so quickly!

Comment 6 Fedora Update System 2010-12-12 20:05:56 UTC
libindi-0.6.2-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.