This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 653696 - Windows XP Pro KVM VM fails for SP2 or SP3
Windows XP Pro KVM VM fails for SP2 or SP3
Status: CLOSED DUPLICATE of bug 650215
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
14
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-15 18:16 EST by Marc Curry
Modified: 2013-01-09 06:42 EST (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-30 10:53:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marc Curry 2010-11-15 18:16:41 EST
Description of problem:
Updating a Windows XP Pro VM to SP2 or SP3 (or installing directly from an SP2 or SP3 spin) causes the VM to fail.

Version-Release number of selected component (if applicable):
qemu-kvm-0.13.0-1.fc14.i686
kernel-PAE-2.6.35.6-48.fc14.i686

How reproducible:
Every time.

Steps to Reproduce:
1. Start with fresh install of Windows XP Pro and then update to SP2, or install directly from an SP2 or SP3 spin.
  
Actual results:
After the SP2 update of an otherwise functional instance of the OS completes and subsequently reboots, or immediately upon trying to instantiate the installation GUI of SP2 or SP3 spins, the VM's CPU goes to 100% and the VM console is totally black and unresponsive. The mouse icon disappears when moving it over/within the console window and it appears dead except for the CPU "spinning". 'Force Off' is the only way to shut down the VM and stop the CPU usage.

Expected results:
The SP2-updated VM should boot to the login GUI and the SP2/SP3-spin installation process should launch the installation GUI without the error.

Additional info:
Fully updated F14 host OS. The updates leading up to the SP2 update do not produce the error.  The SP2-updated VM starts/functions correctly and the desktop GUI is visible when started in Safe Mode.
Comment 1 Justin M. Forbes 2010-11-23 10:19:30 EST
I notice you are using a 32bit host.  Does this work for you with the latest kernel from koji?  For more information see https://bugzilla.redhat.com/show_bug.cgi?id=650215 and let me know if this is a duplicate issue.
Comment 2 Marc Curry 2010-11-29 12:07:02 EST
I just tried with the newest kernel I could find in koji (kernel-PAE-2.6.35.9-62.fc14 from the dist-f14-updates-candidate tag) and it fixes the problem (at least for SP2 -- I didn't go further to SP3, but I suspect it would fix that too).

A new problem arises (very, very slowed interface to the VM's GUI), but that's another bugzilla to file....
Comment 3 Justin M. Forbes 2010-11-30 10:53:04 EST
Great, closing this as a dup of 650215 and will look for your new bug.

*** This bug has been marked as a duplicate of bug 650215 ***

Note You need to log in before you can comment on or make changes to this bug.