Bug 65371 - Virtual eth0:0 interface goes down frequently
Virtual eth0:0 interface goes down frequently
Product: Red Hat Linux
Classification: Retired
Component: net-tools (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2002-05-22 16:10 EDT by Need Real Name
Modified: 2015-03-04 20:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-02-02 09:34:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-05-22 16:10:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc2) Gecko/20020510

Description of problem:
Have a 3Com ethernet card with two interfaces - an eth0 assigned with pump and
an eth0:0 assigned with ifconfig.  It is used for masquerading.  After a
seemingly random amount of time, as little as an hour, the eth0:0 interface will
simply disappear.  ifconfig will not show it, and masquerading stops working
until I run the ifconfig command to bring it up again.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. /sbin/ifconfig eth0:0
2. wait a while

Actual Results:  eventually /sbin/ifconfig will cease to show the interface and
masquerading stops working.

Expected Results:  eth0:0 should have remained up.

Additional info:

It was upgraded from 7.2, where it worked fine.  None of my firewall or
masquerading scripts have changed.
Comment 1 Phil Knirsch 2003-05-23 04:57:00 EDT
Does this still happen on newer releases (RH 8 or 9)? I haven't been able to
reproduce this bug myself, thats why i'm asking.

Read ya, Phil
Comment 2 Phil Knirsch 2003-06-27 06:27:55 EDT
Actually, this sounds like you manually ifconfig the eth0:0 interface and not
with the ifcfg-eth0:0 in the network-scripts directory. This could be the source
of the problem as pump will simply reinit eth0 and the system doesn't know about
your eth0:0 at all.

Also i newer releases we use a different dhcp client, so that might help, too.

Read ya, Phil
Comment 3 Phil Knirsch 2004-02-02 09:34:53 EST
No more info, can't reproduce, closing as works for me.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.