Bug 65372 - Sun's JVM 1.3.1_03 has run-time linking problem with the glibc in rh73
Sun's JVM 1.3.1_03 has run-time linking problem with the glibc in rh73
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-22 16:14 EDT by Ion Badulescu
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-22 16:15:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ion Badulescu 2002-05-22 16:14:57 EDT
Description of Problem:
[I had a much more descriptive entry the first time, but bugzilla ate it when I
tried to submit with the "new and improved" form. So I'll be terse this time.
There is enough info in this bug report for a glibc guru to figure out where the
problem is. Just check to glibc changelog for GLIBC_PRIVATE.]

Version-Release number of selected component (if applicable):
2.2.5-34

How Reproducible:
Depends on the classes being used. However, for a combination of classes that
produces the error, it's 100% reproducible.

Steps to Reproduce:
1. export J2SE_PREEMPTCLOSE=1
2. run java
3. 

Actual Results:
relocation error: /usr/java/jdk1.3.1_03/jre/lib/i386/libpreemptive_close.so:
symbol __libc_sendto, version GLIBC_2.0 not defined in file libc.so.6 with link
time reference

Expected Results:
Guess...

Additional Information:
libpreemptive_close.so (triggered by J2SE_PREEMPTCLOSE=1) is used to unblock
threads sleeping on a file descriptor when that fd is closed in another thread.

Downgrading to the errata version of glibc for rh72 fixes the problem.
Comment 1 Jakub Jelinek 2002-05-23 08:13:26 EDT
The bug is in Sun JDK. It must not use glibc private interfaces (and the difference
between 7.2 and 7.3 is that glibc no enforces this).
Get a newer JDK from Sun (I think they've fixed it already).
Comment 2 Ion Badulescu 2002-05-23 13:01:16 EDT
While I agree in principle, I believe that making this kind of change between 
two supposedly-compatible RH releases is not the best idea. It could have 
waited for 8.0.

Also, for what it's worth, the Blackdown JVM has the same problem (no wonder, 
since it's using Sun's code base). As for Sun fixing it, if they've done it 
then they certainly haven't released anything yet.

Note You need to log in before you can comment on or make changes to this bug.