Bug 653723 - SELinux is preventing /sbin/killall5 from getattr access on the file /usr/sbin/rpc.idmapd.
Summary: SELinux is preventing /sbin/killall5 from getattr access on the file /usr/sbi...
Keywords:
Status: CLOSED DUPLICATE of bug 653721
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:0b6b28d477a...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-16 01:52 UTC by Antonio A. Olivares
Modified: 2010-11-16 10:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-16 10:11:07 UTC


Attachments (Terms of Use)

Description Antonio A. Olivares 2010-11-16 01:52:30 UTC
SELinux is preventing /sbin/killall5 from getattr access on the file /usr/sbin/rpc.idmapd.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you want to allow killall5 to have getattr access on the rpc.idmapd file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep /sbin/killall5 /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:rpcd_exec_t:s0
Target Objects                /usr/sbin/rpc.idmapd [ file ]
Source                        pidof
Source Path                   /sbin/killall5
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           sysvinit-tools-2.88-1.dsf.fc15
Target RPM Packages           nfs-utils-1.2.3-2.fc15
Policy RPM                    selinux-policy-3.9.7-9.fc15
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.35.6-48.fc14.x86_64 #1 SMP Fri Oct 22 15:36:08
                              UTC 2010 x86_64 x86_64
Alert Count                   1
First Seen                    Wed 03 Nov 2010 06:22:05 PM CDT
Last Seen                     Fri 05 Nov 2010 07:04:32 AM CDT
Local ID                      42b4597e-ebb8-4c21-b1e2-b35226b4552f

Raw Audit Messages
type=AVC msg=audit(1288958672.327:81): avc:  denied  { getattr } for  pid=1456 comm="pidof" path="/usr/sbin/rpc.idmapd" dev=dm-0 ino=14141 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:rpcd_exec_t:s0 tclass=file

pidof,xdm_t,rpcd_exec_t,file,getattr
type=SYSCALL msg=audit(1288958672.327:81): arch=x86_64 syscall=stat success=no exit=EACCES a0=7fff12eba510 a1=7fff12eb9460 a2=7fff12eb9460 a3=1 items=0 ppid=1453 pid=1456 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=pidof exe=/sbin/killall5 subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)
pidof,xdm_t,rpcd_exec_t,file,getattr

#============= xdm_t ==============
allow xdm_t rpcd_exec_t:file getattr;

Comment 1 Miroslav Grepl 2010-11-16 10:11:07 UTC

*** This bug has been marked as a duplicate of bug 653721 ***


Note You need to log in before you can comment on or make changes to this bug.