Bug 653814 - satellite-sync does not honor CDN (Location Aware Updates) preferences
satellite-sync does not honor CDN (Location Aware Updates) preferences
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Satellite Synchronization (Show other bugs)
540
i686 Linux
high Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Red Hat Satellite QA List
: Regression
Depends On:
Blocks: sat54-errata
  Show dependency treegraph
 
Reported: 2010-11-16 03:50 EST by Sebastian Skracic
Modified: 2011-02-01 11:16 EST (History)
3 users (show)

See Also:
Fixed In Version: spacewalk-backend-1.2.13-21
Doc Type: Bug Fix
Doc Text:
Cause: Consequence: Fix: Result:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-01 11:16:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch for satellite-sync (706 bytes, patch)
2010-11-16 03:53 EST, Sebastian Skracic
no flags Details | Diff

  None (edit)
Description Sebastian Skracic 2010-11-16 03:50:07 EST
Description of problem:

satellite-sync does not honor CDN (Location Aware Updates) preferences, and always fetches the RHN Hosted content from satellite.rhn.redhat.com.

Version-Release number of selected component (if applicable):

5.4.0

How reproducible:

Always.

Steps to Reproduce:
1. Install 5.4 RHN Satellite
2. Enable 'Support Location-Aware Updates' in RHN Web UI
3. satellite-sync
  
Actual results:

When syncing with RHN Hosted, the satellite fetches the content from satellite.rhn.redhat.com. 

Expected results:

The satellite should honor the CDN flag and sync the downloadable content
from a CDN node physically closer to it, if the flag is turned on.

Additional info:
Comment 1 Sebastian Skracic 2010-11-16 03:53:18 EST
Created attachment 460779 [details]
Proposed patch for satellite-sync
Comment 3 Miroslav Suchý 2010-11-16 05:17:02 EST
It was not caused by that commit. It worked after bug 175155 has been resolved. Most probably the header was previously set somewhere in connection class, but now is not.
Comment 4 Miroslav Suchý 2010-12-07 04:24:27 EST
Commited to spacewalk.git as commit: 5cb052177992490286d2b1974dd9d4ecc4eb012b

According my test it works - from tcpdump:
11:40:58.925327 IP a184-86-88-217.deploy.akamaitechnologies.com.https > dell-pe830-01.rhts.eng.bos.redhat.com.58338: . ack 122 win 181 <nop,nop,timestamp 1153604066 8916324>
11:40:58.926283 IP a184-86-88-217.deploy.akamaitechnologies.com.https > dell-pe830-01.rhts.eng.bos.redhat.com.58338: . 1:1349(1348) ack 122 win 181 <nop,nop,timestamp 1153604067 8916324>
Comment 5 Miroslav Suchý 2010-12-16 12:22:28 EST
cherrypicked to satellite.git as 236c7532170d1a406fef54b21046e97d62099ae0
Comment 6 Miroslav Suchý 2010-12-16 12:25:23 EST
err.. that cherrypick is commit 236c7532170d1a406fef54b21046e97d62099ae0
Comment 7 Šimon Lukašík 2011-01-06 11:41:50 EST
Changing to VERIFIED:

After the discussion with developers I have done basic blackbox testing
of satellite-sync. With spacewalk-backend-tools-1.2.13-23.el5sat
satellite-sync fetches rpms from akamai.
Comment 9 Florian Nadge 2011-01-27 06:27:17 EST
Please be so kind and add a few key words to the technical note of this
bugzilla entry using the following structure:

Cause:

Consequence:

Fix:

Result:


For details, see:
https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thanks
Comment 10 Florian Nadge 2011-01-27 06:27:18 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause:

Consequence:

Fix:

Result:
Comment 11 Miroslav Suchý 2011-01-27 07:12:22 EST
There is already nice text in errata.
Comment 12 errata-xmlrpc 2011-02-01 11:16:28 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0190.html

Note You need to log in before you can comment on or make changes to this bug.