Bug 65382 - Kernel panic: No init found with ServeRaid controller (ips driver)
Kernel panic: No init found with ServeRaid controller (ips driver)
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i686 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-22 17:31 EDT by Zing
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-28 16:06:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
serial console capture (7.32 KB, text/plain)
2002-05-27 12:02 EDT, Zing
no flags Details

  None (edit)
Description Zing 2002-05-22 17:31:09 EDT
Description of Problem:
Upgrade RH 7.2 -> RH 7.3 on IBM xSeries 342 with ServeRaid 4M controller.
Install completes, reboots and get:

Mounting root filesystem
EXT3-fs:unable to read superblock
mount: error 22 mounting ext3
pivotroot: pivot_root(/sysroot,/sysroot/initrd) failed: 2
Freeing unused kernel memory: 280K freed
Kernel panic: No init found.  Try passing init= option to kernel.

Usually I see the disks detected in the raid array in 7.2, but no such luck
in 7.3.  I have two disks software raid 1 on an adaptec which are detected
fine right before these error messages above.


Version-Release number of selected component (if applicable):

Red Hat 7.3

How Reproducible:
always.

Steps to Reproduce:
1. IBM Serveraid controller
2. Upgrade 7.2 to 7.3
3. after install finishes, reboot, and kernel panic

Actual Results:
kernel panic: no init found

Expected Results:
boot into system

Additional Information:
seems similar to other bugreports with other raid controllers.
this is a uniprocessor machine, but same symptoms on an SMP machine (xseries 340)
we have here.
Comment 1 Arjan van de Ven 2002-05-27 10:59:52 EDT
Is there anything before this that indicates that the ips driver is loaded at all ?
Comment 2 Zing 2002-05-27 12:01:11 EDT
Sorry, my bad arjan... the ips driver is being loaded.  :(

I'm attaching a serial capture of the actual boot...
Comment 3 Zing 2002-05-27 12:02:18 EDT
Created attachment 58685 [details]
serial console capture
Comment 4 Arjan van de Ven 2002-05-28 05:13:22 EDT
Hm. This almost looks like during the installation the ips is found first and
then the aic7xxx, while now the aic7xxx is loaded first and then the ips.

In theory mount-by-label should have avoided this.

Matt: have you seen similar reports from your side ?
Comment 5 Matt Wilson 2002-05-28 11:11:23 EDT
haven't seen simiar reports yet.
Comment 6 Zing 2002-05-28 16:06:11 EDT
Errrr, I can boot now.  The /initrd directory was missing... i have no idea why
(all I did was an upgrade & rebooted immediately and then kernel panic, honest!
:).  

I did a `mkdir /mnt/sysimage/initrd` in rescue mode, rebooted, and the system
came up fine using grub & kernel-2.4.18-3.
Comment 7 Matt Wilson 2002-05-28 16:14:20 EDT
thought that'd be the problem.

Note You need to log in before you can comment on or make changes to this bug.