Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 653887 - [abrt] eric-4.4.8-1.fc13: eric4-trpreviewer.py:74:main:NameError: global name 'KQApplication' is not defined
Summary: [abrt] eric-4.4.8-1.fc13: eric4-trpreviewer.py:74:main:NameError: global name...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: eric
Version: 13
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:733b2ab0
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-16 11:34 UTC by Prinse Wang
Modified: 2011-05-17 01:00 UTC (History)
3 users (show)

Fixed In Version: eric-4.4.13-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-05-17 01:00:04 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (1.03 KB, text/plain)
2010-11-16 11:34 UTC, Prinse Wang
no flags Details

Description Prinse Wang 2010-11-16 11:34:12 UTC
abrt version: 1.1.13
architecture: x86_64
cmdline: /usr/bin/python /usr/lib/python2.6/site-packages/eric4/eric4-trpreviewer.py --version
component: eric
executable: /usr/lib/python2.6/site-packages/eric4/eric4-trpreviewer.py
kernel: 2.6.34.7-61.fc13.x86_64
package: eric-4.4.8-1.fc13
reason: eric4-trpreviewer.py:74:main:NameError: global name 'KQApplication' is not defined
release: Fedora release 13 (Goddard)
time: 1289907220
uid: 500

backtrace
-----
eric4-trpreviewer.py:74:main:NameError: global name 'KQApplication' is not defined

Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/eric4/eric4-trpreviewer.py", line 93, in <module>
    main()
  File "/usr/lib/python2.6/site-packages/eric4/eric4-trpreviewer.py", line 74, in main
    app = KQApplication(sys.argv, kqOptions)
NameError: global name 'KQApplication' is not defined

Local variables in innermost frame:
appinfo: {'bin': '/usr/lib/python2.6/site-packages/eric4/eric4-trpreviewer.py', 'description': 'TR file previewer', 'version': '4.4.8 (r3828)', 'arg': 'file', 'options': [('--config=configDir', 'use the given directory as the one containing the config files'), ('--nokde', "don't use KDE widgets")], 'name': 'Eric4 TR Previewer'}
kqOptions: [('config \\', 'use the given directory as the one containing the config files'), ('nokde', "don't use KDE widgets"), ('!+file', '')]
options: [('--config=configDir', 'use the given directory as the one containing the config files'), ('--nokde', "don't use KDE widgets")]

Comment 1 Prinse Wang 2010-11-16 11:34:15 UTC
Created attachment 460813 [details]
File: backtrace

Comment 2 Kerry 2011-01-06 05:17:47 UTC
Package: eric-4.4.8-1.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Settings | Show external tools
2.
3.

Comment 3 Rex Dieter 2011-05-06 13:54:41 UTC
can't reproduce this one. :(

Comment 4 Fedora Update System 2011-05-06 14:50:02 UTC
eric-4.4.13-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/eric-4.4.13-1.fc13

Comment 5 Fedora Update System 2011-05-07 13:26:06 UTC
Package eric-4.4.13-1.fc13:
* should fix your issue,
* was pushed to the Fedora 13 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing eric-4.4.13-1.fc13'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/eric-4.4.13-1.fc13
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2011-05-17 00:59:45 UTC
eric-4.4.13-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.