Bug 653893 - Upgrade breaks osa-dispatcher
Summary: Upgrade breaks osa-dispatcher
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Spacewalk
Classification: Community
Component: Installation
Version: 1.2
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Jan Pazdziora
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space12
TreeView+ depends on / blocked
 
Reported: 2010-11-16 12:07 UTC by Sandro Mathys
Modified: 2010-11-19 16:16 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-19 16:16:20 UTC


Attachments (Terms of Use)

Description Sandro Mathys 2010-11-16 12:07:11 UTC
Description of problem:
osa-dispatcher doesn't work anymore after an upgrade from spacewalk 1.1 to 1.2 RC

Version-Release number of selected component (if applicable):
http://koji.spacewalkproject.org/spacewalk/split/spacewalk-5E/server/spacewalk-5E-1.2/x86_64/os/

How reproducible:
Only tried upgrading once

Steps to Reproduce:
1. Follow instructions at https://fedorahosted.org/spacewalk/wiki/HowToUpgrade
2. When finished (and rhn-satellite started) tail /var/log/rhn/osa-dispatcher.log
  
Actual results:
2010/11/16 13:01:41 +02:00 22693 0.0.0.0: rhnSQL/driver_cx_Oracle.connect('Connecting to database', '#####')
2010/11/16 13:01:42 +02:00 22693 0.0.0.0: osad/jabber_lib.__init__
2010/11/16 13:01:42 +02:00 22693 0.0.0.0: osad/jabber_lib.setup_connection('Connected to jabber server', '#####')
2010/11/16 13:01:42 +02:00 22693 0.0.0.0: osad/jabber_lib.register('ERROR', 'Invalid password')

Expected results:
no ERROR :)

Additional info:
osa-dispatcher says [ OK ] when started but is not running thereafter.

Comment 1 Sandro Mathys 2010-11-16 14:13:25 UTC
Okay so this is probably because .rpmnew files were generated and ignored. Using them fixes the above issue - but created some new problems of which I can't say for sure it's a bug in the code or things we modified before.

1) localhost.localdomain instead of the real fqdn is used
2) the path to the server.pem is incorrect.

NOTABUG, but setting ON_QA - somebody please have an eye on this.

Comment 2 Jan Pazdziora 2010-11-19 16:16:20 UTC
With Spacewalk 1.2 released, marking as CLOSED CURRENTRELEASE.

https://www.redhat.com/archives/spacewalk-list/2010-November/msg00111.html


Note You need to log in before you can comment on or make changes to this bug.