This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 653899 - 3 options are missing in seinfo man page
3 options are missing in seinfo man page
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: setools (Show other bugs)
6.0
All Linux
low Severity low
: rc
: ---
Assigned To: Daniel Walsh
Milos Malik
: ManPageChange, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-16 07:35 EST by Milos Malik
Modified: 2012-03-07 14:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-07 14:45:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Milos Malik 2010-11-16 07:35:17 EST
Description of problem:
Following options are not documented in the man page:
	--line-breaks
	--permissive
	--polcap

Version-Release number of selected component (if applicable):
setools-devel-3.3.7-4.el6.i686
setools-3.3.7-4.el6.i686
setools-libs-java-3.3.7-4.el6.i686
setools-libs-3.3.7-4.el6.i686
setools-libs-python-3.3.7-4.el6.i686
setools-console-3.3.7-4.el6.i686
setools-gui-3.3.7-4.el6.i686
setools-libs-tcl-3.3.7-4.el6.i686

How reproducible:
always

Additional info:
# ./compare-options.sh `which seinfo`
Program path:
	/usr/bin/seinfo
Man pages found:
	/usr/share/man/man1/seinfo.1.gz
According to binary analysis the binary supports 34 option(s):
	--all
	--attribute
	--bool
	--category
	--class
	--constrain
	--expand
	--fs_use
	--genfscon
	--help
	--initialsid
	--line-breaks
	--netifcon
	--nodecon
	--permissive
	--polcap
	--portcon
	--protocol
	--role
	--sensitivity
	--stats
	--type
	--user
	--version
	-V
	-a
	-b
	-c
	-h
	-l
	-r
	-t
	-u
	-x
Usage message contains 0 UNSUPPORTED option(s):
Usage message OMITS 0 supported option(s):
Man page contains 0 UNSUPPORTED option(s):
Man page OMITS 3 supported option(s):
	--line-breaks
	--permissive
	--polcap
#
Comment 1 RHEL Product and Program Management 2011-01-07 10:56:34 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.
Comment 4 Daniel Walsh 2012-03-07 14:39:51 EST
These are fixed in latest fedoras I don't see the need to update this package for these fixes.
Comment 5 RHEL Product and Program Management 2012-03-07 14:45:00 EST
Development Management has reviewed and declined this request.  You may appeal
this decision by reopening this request.

Note You need to log in before you can comment on or make changes to this bug.