Bug 653906 - SSM: action remote command is scheduled to system without ability of remote command
Summary: SSM: action remote command is scheduled to system without ability of remote c...
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Usability
Version: 540
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: Justin Sherrill
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: 462714
TreeView+ depends on / blocked
 
Reported: 2010-11-16 13:07 UTC by Petr Sklenar
Modified: 2014-07-04 13:25 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-04 13:25:34 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Petr Sklenar 2010-11-16 13:07:19 UTC
Description of problem:
action remote command is scheduled to system without ability of remote command

Version-Release number of selected component (if applicable):
latest sat540

How reproducible:
always

Steps to Reproduce:
1. have 5 systems in SSM with provisioning entitlement
2. first 4 systems : enable remote command by rhn-actions-control --enable-all
# the fifth system is not enabled for remote command now
3. click to SSM > remote command
4. add remote command:
#!/bin/sh
wall ahoj2
5. schedule action
6. you will see 4 systems in list and click schedule
# there is NOT the fifth system - which is OK
7. 4 systems: rhn_check and action is picked up as expected
8. the fifth system without remote command ability: rhn_check fails
  
Actual results:
log from the fifth system without remote command ability:
rhn_check -vv
D: check_action {'action': "<?xml version='1.0'?>\n<methodCall>\n<methodName>script.run</methodName>\n<params>\n<param>\n<value><int>5216</int></value>\n</param>\n<param>\n<value><struct>\n<member>\n<name>username</name>\n<value><string>root</string></value>\n</member>\n<member>\n<name>groupname</name>\n<value><string>root</string></value>\n</member>\n<member>\n<name>now</name>\n<value><string>2010-11-16 13:58:12</string></value>\n</member>\n<member>\n<name>timeout</name>\n<value><int>600</int></value>\n</member>\n<member>\n<name>script</name>\n<value><string>#!/bin/sh\nwall ahoj3</string></value>\n</member>\n</struct></value>\n</param>\n</params>\n</methodCall>\n", 'version': 2, 'id': 5216}
updateLoginInfo() login info
D: login(forceUpdate=True) invoked
logging into up2date server
D: writeCachedLogin() invoked
D: Wrote pickled loginInfo at  1289912292.33  with expiration of  1289915892.33  seconds.
successfully retrieved authentication token from up2date server
D: logininfo: {'X-RHN-Server-Id': 1000011671, 'X-RHN-Auth-Server-Time': '1289912292.29', 'X-RHN-Auth': 'B67CSs71UTSAB6NhPLmdSg==', 'X-RHN-Auth-Channels': [['rhel-ia64-server-5', '20101116131244', '1', '1']], 'X-RHN-Auth-User-Id': '', 'X-RHN-Auth-Expire-Offset': '3600.0'}
D: handle_action {'action': "<?xml version='1.0'?>\n<methodCall>\n<methodName>script.run</methodName>\n<params>\n<param>\n<value><int>5216</int></value>\n</param>\n<param>\n<value><struct>\n<member>\n<name>username</name>\n<value><string>root</string></value>\n</member>\n<member>\n<name>groupname</name>\n<value><string>root</string></value>\n</member>\n<member>\n<name>now</name>\n<value><string>2010-11-16 13:58:12</string></value>\n</member>\n<member>\n<name>timeout</name>\n<value><int>600</int></value>\n</member>\n<member>\n<name>script</name>\n<value><string>#!/bin/sh\nwall ahoj3</string></value>\n</member>\n</struct></value>\n</param>\n</params>\n</methodCall>\n", 'version': 2, 'id': 5216}
D: handle_action actionid = 5216, version = 2
D: do_call script.run (5216, {'username': 'root', 'groupname': 'root', 'now': '2010-11-16 13:58:12', 'timeout': 600, 'script': '#!/bin/sh\nwall ahoj3'}) {'cache_only': None}
D: Attempt to call an unsupported action script.run (5216, {'username': 'root', 'groupname': 'root', 'now': '2010-11-16 13:58:12', 'timeout': 600, 'script': '#!/bin/sh\nwall ahoj3'})
D: Sending back response (6, 'Invalid function call attempted', {})
D: do_call packages.checkNeedUpdate ('rhnsd=1',) {}
Loaded plugins: rhnplugin
D: local action status:  (0, 'rpm database not modified since last update (or package list recently updated)', {})


Expected results:
action is not scheduled for the fifth system

Additional info:


Note You need to log in before you can comment on or make changes to this bug.