Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 653968 - Too strict directory permissions shouldn't be an error
Summary: Too strict directory permissions shouldn't be an error
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: rpmlint
Version: rawhide
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-16 14:37 UTC by Matěj Cepl
Modified: 2018-04-11 14:29 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-25 01:06:53 UTC
Type: ---


Attachments (Terms of Use)
message from autoqa (6.46 KB, message/rfc822)
2010-11-16 14:37 UTC, Matěj Cepl
no flags Details

Description Matěj Cepl 2010-11-16 14:37:44 UTC
Created attachment 460848 [details]
message from autoqa

Description of problem:
I've got a message from autoqa@fedoraproject.org saying among other things that

spectrum.ppc: E: non-standard-dir-perm /var/run/spectrum 0700L
(and the same for /var/{log,lib}/spectrum).

I may accept that it is slightly to draconic, but upstream wants it and I don't see any hurt which would it cause to anybody.

Please, make this into warning (which should be waiveable, but that's other issue).

Version-Release number of selected component (if applicable):
what's on autoqa@fedoraproject.org today

How reproducible:
100%

Comment 1 Fedora Admin XMLRPC Client 2010-12-07 21:18:48 UTC
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.

Comment 2 Tom "spot" Callaway 2011-04-25 01:06:53 UTC
The short answer here is that the check isn't that smart, nor is there any real way for it to be. It just knows that 0700L is a non-standard permission for /var/run/spectrum and /var/{log,lib}/spectrum, which is true. How should it know that in the case of spectrum, this is okay, when for another package, it would not be?

Using your own common sense here will be the best recourse. Also, in the context of autoqa, hopefully it will be possible on a per-package basis to filter out specific rpmlint errors/warnings that the packager knows to be false positives.

Closing as WONTFIX

Comment 3 Ville Skyttä 2011-04-25 08:11:40 UTC
(In reply to comment #2)
> Also, in the
> context of autoqa, hopefully it will be possible on a per-package basis to
> filter out specific rpmlint errors/warnings that the packager knows to be false
> positives.

From rpmlint POV this is technically possible, just install desired *config snippets that do the filtering to /etc/rpmlint/.  Packages can also install their own snippets there, but that doesn't work too well because the packages need to be installed before the filters take effect, so I think it'd be better if autoqa would install those files.


Note You need to log in before you can comment on or make changes to this bug.