Bug 6540 - No option to remove a lot of file together
No option to remove a lot of file together
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: fileutils (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-30 11:04 EDT by mark
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-15 14:23:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mark 1999-10-30 11:04:20 EDT
The rm program (as well as many other utilities) is limited
by the number of file it can delete due to the limited
size of the os command line. This prevents a lot of elegant
solutions in high level tools. For instance, I am using
a building tool (make replacement) called "cook" which is
excellent. I work on a project with 2500 source files
(and 2500 objects). I want to be able to just say:
rm "file1.o file2.o ... file2500.o"
but this is impossible and make me sad.
What I did is to write a program which receives the list of
files from stdin (or a file) which is limitless, and call
rm to remove them. I think this should be a feature of rm.
An idea about command line usage could be:
	rm --file file.txt
and the interpretation would be that rm will read the
"file.txt" file and remove all files which are specified
in it... The format of file.txt could be the cause of
a few more options to rm...:)

Regarding redirection of this bug:
Since the GNU people are responsible for "rm" you probably
need to mail this to them (I couldnt find a place in
their site for reporting bugs...)

					Mark.
Comment 1 Preston Brown 1999-11-15 14:23:59 EST
see the man page for 'xargs'.  It was specifically designed for handling this
sort of case.

Note You need to log in before you can comment on or make changes to this bug.