Bug 65403 - RHL72 -> RHL73 update broke php-imap when due to SSL
RHL72 -> RHL73 update broke php-imap when due to SSL
Status: CLOSED DUPLICATE of bug 65190
Product: Red Hat Linux
Classification: Retired
Component: php (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Phil Copeland
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-23 04:23 EDT by Pekka Savola
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-23 04:23:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Savola 2002-05-23 04:23:26 EDT
I upgraded RHL72 system to RHL73; a system including apache, php, php-imap, imap
packages (among others).

Imp 2.2.8 broke.  It would not longer let you log in:

May 18 12:39:08 otso imapd[14639]: imap service init from 127.0.0.1
May 18 12:39:08 otso imapd[14639]: Command stream end of file, while 
reading line user=??? host=UNKNOWN

I run tcpdump on localhost and noticed php-imap sends a starttls command after
which the 
connection is reset.

Pine, connecting with SSL-IMAP to localhost worked.

There are two explanations for this:
 1) SSL-IMAP server with STARTTLS doesn't work well (unprobable as pine worked
nicely)
 2) PHP's imap SSL does not work with SSL-enabled IMAP properly
(e.g. one possibility might be it doesn't like self-signed certificates).

Recompiling imapd without SSL support (so it doesn't advertise it with STARTTLS)
fixed this problem, so I suspect PHP's IMAP-SSL support is at fault here.  I
couldn't verify this as I didn't have all the buildprereq's to recompile PHP.
Comment 1 Phil Copeland 2002-05-23 10:11:11 EDT
Be aware of /novalidate-cert

See duplicate bug report explaination

Phil
=--=

*** This bug has been marked as a duplicate of 65190 ***

Note You need to log in before you can comment on or make changes to this bug.