Bug 654034 - USB soundcard says "not enough bandwidth"
Summary: USB soundcard says "not enough bandwidth"
Keywords:
Status: CLOSED DUPLICATE of bug 527813
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-16 17:14 UTC by Bastien Nocera
Modified: 2012-03-28 13:04 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 844663 (view as bug list)
Environment:
Last Closed: 2012-03-28 13:04:14 UTC


Attachments (Terms of Use)

Description Bastien Nocera 2010-11-16 17:14:46 UTC
kernel-2.6.36-1.fc15.x86_64

[1213091.509996] usb 2-1.3: new full speed USB device using ehci_hcd and address 11
[1213091.591083] usb 2-1.3: New USB device found, idVendor=0ccd, idProduct=0028
[1213091.596595] usb 2-1.3: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[1213091.602050] usb 2-1.3: Product: USB Audio
[1213091.648054] input: USB Audio as /devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.3/2-1.3:1.3/input/input10
[1213091.654238] generic-usb 0003:0CCD:0028.0008: input,hidraw5: USB HID v1.00 Device [USB Audio] on usb-0000:00:1d.0-1.3/input3
[1213092.330580] ALSA sound/usb/urb.c:838: cannot submit datapipe for urb 0, error -28: not enough bandwidth

There are quite a few USB devices on this machine, but only 3 external ones (the Belkin Bluetooth dongle, on the side of the machine, and a hard drive and the sound card at the back):
Bus 002 Device 011: ID 0ccd:0028 TerraTec Electronic GmbH Aureon 5.1 MkII
Bus 002 Device 008: ID 04c5:201d Fujitsu, Ltd 
Bus 002 Device 007: ID 050d:016a Belkin Components Bluetooth Mini Dongle
Bus 002 Device 006: ID 0a5c:4503 Broadcom Corp. 
Bus 002 Device 005: ID 0a5c:4502 Broadcom Corp. Keyboard (Boot Interface Subclass)
Bus 002 Device 004: ID 04e7:0022 Elo TouchSystems 
Bus 002 Device 003: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 002 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 006: ID 0a5c:4503 Broadcom Corp. 
Bus 001 Device 005: ID 0a5c:4502 Broadcom Corp. Keyboard (Boot Interface Subclass)
Bus 001 Device 004: ID 0ac8:c42d Z-Star Microelectronics Corp. 
Bus 001 Device 003: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
Bus 001 Device 002: ID 8087:0020 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Comment 1 Chuck Ebbert 2010-12-09 15:56:44 UTC
There's not much we can do about that, since the card wants to reserve enough bandwidth to handle audio output and other devices prevent that from happening.

Comment 2 Joel F 2011-09-21 22:31:11 UTC
I get this error with an Edirol UA-25ex, which has been working before in full-duplex mode on an USB2.0 port. But since I upgraded to F15 and later I get this error even if I unplug all the other usb-devices.

I googled and found the experimental CONFIG_USB_BANDWIDTH. I will try compile a kernel with that enabled to see if it affects the problem.

Q: Is there a way to display the USB bandwidth allocations?

Comment 3 Joel F 2011-09-21 23:30:36 UTC
Or wait, is it my internal devices (Root hubs) on the bus that is preventing my USB v1.1 from getting enough bandwidth from a USB 2.0 port?

I should also add that it only happens in the advanced mode of the UA-25ex. It should be able to work in full duplex even then except on 96kHz sampling.

Comment 4 Joel F 2012-03-28 07:11:11 UTC
This was a duplicate of bug 527813, and was fixed with kernel-3.3.0-4.fc16
Please close this bug

Comment 5 Josh Boyer 2012-03-28 13:04:14 UTC
Thanks for letting us know.

*** This bug has been marked as a duplicate of bug 527813 ***


Note You need to log in before you can comment on or make changes to this bug.