Bug 65405 - xscreensaver locks machine with SMP kernel 2.4.18-4
xscreensaver locks machine with SMP kernel 2.4.18-4
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
athlon Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-23 05:53 EDT by Michel Alexandre Salim
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-26 08:39:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michel Alexandre Salim 2002-05-23 05:53:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i686; U;) Gecko/20020408

Description of problem:
When running the SMP kernel, after xscreensaver is active for a while the
machine is locked up solid. If the screen is still on (power management has not
kicked in) the screen is frozen, if the display has been suspended it remains
blank after turning on the screen.

Would not respond to CTRL+ALT+DEL, I had to manually turn the machine off. Have
not tried SysRq yet.

Just noticed this problem as I was running GNOME2 snapshots before (totally
uninstalled since).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot athlon SMP kernel
2. Lock screen
3. Wait
	

Actual Results:  System froze after a while - I noticed as I had XMMS playing an
album and it just stopped after a while - at the end of a song, actually.

Expected Results:  System runs as normal.

Additional info:

xscreensaver version 3.33-4
kernel-smp: 2.4.18-4

System kept up to date using up2date
Comment 1 Bill Nottingham 2002-05-23 10:13:07 EDT
What sort of graphics chip?
Comment 2 Michel Alexandre Salim 2002-05-24 05:39:38 EDT
ATI Radeon 7000. I overrode the detected 'ATI Radeon VE' that Red Hat and
Windows both detects. Should I try the GATOS drivers?

No problem using UP kernel, btw.
Comment 3 Mike A. Harris 2002-05-24 21:42:20 EDT
The Radeon 7000 *is* a Radeon VE.  ATI changed the name of the card.
So the autodetection is 100% correct.

There are some DRI related problems with Radeon on 4.2.0 which are currently
under investigation.  Try disabling DRI for now to see if that provides
stability.  Report back if disabling DRI makes the problem go away.
Comment 4 Michel Alexandre Salim 2002-05-31 12:15:59 EDT
It does go away when DRI is commented out in XF86Config-4. Hope it gets fixed
soon - guess I'll disable the screensaver for now.

Thanks,

Michel
Comment 5 Mike A. Harris 2002-07-26 07:59:42 EDT
Please attach your X server log file, XF86Config-4, and /var/log/messages
after a crash/lockup.
Comment 6 Michel Alexandre Salim 2002-07-26 08:38:56 EDT
I'm afraid I cannot at the moment; machine is in storage since I'm interning 
out of town.

Sorry,

Michel
Comment 7 Mike A. Harris 2002-07-26 10:30:22 EDT
If you're still interested in having this troubleshooted/debugged when
the machine is available to you again, please reopen the report, and
provide the information requested above, and I'll be glad to readdress
the issue.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.