Bug 65407 - Touchpad doesn't allow click+drag after wake from sleep
Touchpad doesn't allow click+drag after wake from sleep
Status: CLOSED DUPLICATE of bug 63509
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2002-05-23 07:01 EDT by jaffe
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-06-03 05:53:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description jaffe 2002-05-23 07:01:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.7-10 i686)

Description of problem:
On my latitude L400 with synaptic touchpad, I can no longer click & drag with
the touchpad or buttons 1 and 3 after a wake from sleep. Button 2 -- emulated by
XFree86 -- works fine.

Restarting X fixes the problem.

I have also tried using the 'repeater' option in GPM but that does not solve the

This was not a problem in RH7.2, so it seems likely/possible that it's an
XFree86 4.2.0 problem.

Version-Release number of selected component (if applicable):

How reproducible:

Additional info:
Comment 1 Mike A. Harris 2002-05-28 05:56:25 EDT
This is very likely due to clock skew changes.  Are you automating clock
syncronization, or changing the time after resume in any way?  If not,
it is possible your clock is not keeping accurate time.

The X11 protocol is _very_ sensitive to clock skew since protocol messages
are timestamped.
Comment 2 jaffe 2002-05-31 07:34:28 EDT
Hmmm, I admit I'm not completely sure what 'clock skew changes' are, but I don't
do any clock-synching, and I only restart the services named and gpm and
otherwise use the standard apm script.

Comment 3 Need Real Name 2002-06-03 05:53:15 EDT
Looks similar to bug #63509
Comment 4 Mark J. Cox (Product Security) 2002-06-03 06:01:20 EDT

*** This bug has been marked as a duplicate of 63509 ***

Note You need to log in before you can comment on or make changes to this bug.