Bug 654099 - Gnumeric file history shows ODT files
Summary: Gnumeric file history shows ODT files
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gnumeric
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Huzaifa S. Sidhpurwala
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-16 21:13 UTC by Sara L. Uckelman
Modified: 2010-12-13 20:08 UTC (History)
2 users (show)

Fixed In Version: goffice-0.8.12-1.fc13
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-17 20:51:41 UTC


Attachments (Terms of Use)
screenshot of file menu in gnumeric showing file history with two odt files. (170.46 KB, image/jpeg)
2010-11-16 22:52 UTC, Sara L. Uckelman
no flags Details
error message after trying to open "middle-oscar.odt" in gnumeric from the file history menu. (187.86 KB, image/png)
2010-11-16 22:54 UTC, Sara L. Uckelman
no flags Details


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 635111 None None None Never

Description Sara L. Uckelman 2010-11-16 21:13:40 UTC
Description of problem: The file history part of the "File" menu of gnumeric shows ODT files, even though these ODT files cannot be opened by gnumeric.


Version-Release number of selected component (if applicable): 1.10.10.


How reproducible: Every time


Steps to Reproduce: Go to open office.  Open a few ODT files.  Go to gnumeric.  Click on "File".  Look at the list of recently opened files.  You'll see the ODT files there, in the other they were most recently used in open office.


Expected results:  Since the ODT files cannot be opened by gnumeric, they should not appear in the file history list at all.


Additional info:

Comment 1 Julian Sikorski 2010-11-16 22:48:00 UTC
http://projects.gnome.org/gnumeric/doc/sect-file-open-formats.shtml
It says these files can be opened.

Comment 2 Sara L. Uckelman 2010-11-16 22:52:34 UTC
Created attachment 460946 [details]
screenshot of file menu in gnumeric showing file history with two odt files.

Comment 3 Sara L. Uckelman 2010-11-16 22:53:21 UTC
Well, then I've got another bug to report I guess.

I'm attaching two screenshots; one is of the "file" menu in gnumeric, the second is the error message I get when I click on the second entry (middle-oscar.odt).

Comment 4 Sara L. Uckelman 2010-11-16 22:54:03 UTC
Created attachment 460948 [details]
error message after trying to open "middle-oscar.odt" in gnumeric from the file history menu.

Comment 5 Fedora Update System 2010-12-05 07:39:02 UTC
gnome-chemistry-utils-0.12.5-2.fc13,gnumeric-1.10.12-1.fc13,goffice-0.8.12-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/gnome-chemistry-utils-0.12.5-2.fc13,gnumeric-1.10.12-1.fc13,goffice-0.8.12-1.fc13

Comment 6 Fedora Update System 2010-12-05 07:39:13 UTC
goffice-0.8.12-1.fc14,gnome-chemistry-utils-0.12.5-2.fc14,gnumeric-1.10.12-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/goffice-0.8.12-1.fc14,gnome-chemistry-utils-0.12.5-2.fc14,gnumeric-1.10.12-1.fc14

Comment 7 Fedora Update System 2010-12-12 20:06:51 UTC
gnome-chemistry-utils-0.12.5-2.fc14, gnumeric-1.10.12-1.fc14, goffice-0.8.12-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 8 Fedora Update System 2010-12-13 20:08:53 UTC
goffice-0.8.12-1.fc13, gnome-chemistry-utils-0.12.5-2.fc13, gnumeric-1.10.12-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.