Bug 65413 - 7.3 Anaconda misconfigures XF86 - missing mouse pointer
7.3 Anaconda misconfigures XF86 - missing mouse pointer
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-23 10:43 EDT by Derek Price
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-05-23 10:43:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Derek Price 2002-05-23 10:43:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020516

Description of problem:
The mouse pointer disappeared after installing RH 7.3.  It worked, but was
invisible.

A quick usenet search turned up a work-around - add `Option "sw_cursor"' to the
`Device' section of the XF86Config-4 file.  I tried `Option "hw_cursor"' as well
but this produced the same invisible cursor, so I am unsure whether to
catagorize this as a video driver bug or an anaconda misconfiguration, but an
anaconda fix should be sufficient to fix the problem for most people, even if it
isn't optimal.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1.Update to RH 7.3
2.Run Gnome.
3.
	

Actual Results:  Mouse pointer was not visable.

Expected Results:  Mouse pointer should be visable.

Additional info:

I am running RH 7.3 on a Sony Vaio PCG-XG18.  The video card is a NeoMagic
256XL+ and my XF86Config-4 was configured to use the neomagic driver.
Comment 1 Mike A. Harris 2002-05-23 22:43:31 EDT
This problem only occurs when upgrading from a previous release to Red Hat
Linux 7.3 using neomagic chipsets.  The current video driver has messed
up hardware cursor support.

If a fresh OS install is done instead of an upgrade, then the right thing
happens, and the software cursor is configured.  Also, if you manually
run Xconfigurator post-upgrade, the card will be configured properly.  The
problem only occurs when using an old config file with the new X.  Short
of nasty card specific kludges/hacks, there is no way to cleanly detect
these sort of situations and work around them.  That is also magnified by
the fact the problem wasn't known until after 7.3 was released.

So, for now, the official solution is to rerun Xconfigurator.  Closing
as WORKSFORME since bugzilla doesn't really have a decent resolution
type for this particular kind of solution/workaround.
Comment 2 Mike A. Harris 2002-05-23 22:47:42 EDT
One thing I wasn't clear about in the above, is the actual way the problem
occurs.  Here is what happens - during an upgrade, if you do not reconfigure
XFree86, then the old config file is left intact.  If the old configuration
for any reason is incompatible with the new X, or if the new X requires
any specific config changes for your particular hardware, then it may not
function correctly until you reconfigure with Xconfigurator.

Again, there's no way to automatically detect these types of scenarios
unfortunately.  The good thing though, is that this type of problem is very
very rare, so it isn't a major issue.

Note You need to log in before you can comment on or make changes to this bug.