Bug 654170 - The attached disks are not recognized by guest
The attached disks are not recognized by guest
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
Unspecified Unspecified
low Severity medium
: rc
: ---
Assigned To: Kevin Wolf
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-11-16 21:52 EST by Suqin Huang
Modified: 2011-07-28 10:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-28 10:51:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Suqin Huang 2010-11-16 21:52:52 EST
Description of problem:
Attached 12 disks when boot guest, guest can not recognize them.

Version-Release number of selected component (if applicable):

kvm-83-207.el5

How reproducible:
100%

Steps to Reproduce:
1.
/usr/libexec/qemu-kvm -monitor stdio -drive file='/home/autotest/client/tests/kvm/images/RHEL-Server-6.0-32-virtio.qcow2',index=0,if=virtio,media=disk,cache=none,boot=on,format=qcow2 -drive file='/home/autotest/client/tests/kvm/images/storage.qcow2',index=3,if=virtio,media=disk,cache=none,format=qcow2 -drive file='/home/autotest/client/tests/kvm/images/storage2.qcow2',index=4,if=virtio,media=disk,cache=none,format=qcow2 -drive file='/home/autotest/client/tests/kvm/images/storage3.qcow2',index=5,if=virtio,media=disk,cache=none,format=qcow2 -drive file='/home/autotest/client/tests/kvm/images/storage4.qcow2',index=6,if=virtio,media=disk,cache=none,format=qcow2 -drive file='/home/autotest/client/tests/kvm/images/storage5.qcow2',index=7,if=virtio,media=disk,cache=none,format=qcow2 -drive file='/home/autotest/client/tests/kvm/images/storage6.qcow2',index=8,if=virtio,media=disk,cache=none,format=qcow2 -drive file='/home/autotest/client/tests/kvm/images/storage7.qcow2',index=9,if=virtio,media=disk,cache=none,format=qcow2 -drive file='/home/autotest/client/tests/kvm/images/storage8.qcow2',index=10,if=virtio,media=disk,cache=none,format=qcow2 -drive file='/home/autotest/client/tests/kvm/images/storage9.qcow2',index=11,if=virtio,media=disk,cache=none,format=qcow2 -drive file='/home/autotest/client/tests/kvm/images/storage10.qcow2',index=12,if=virtio,media=disk,cache=none,format=qcow2 -drive file='/home/autotest/client/tests/kvm/images/storage11.qcow2',index=13,if=virtio,media=disk,cache=none,format=qcow2 -net nic,vlan=0,model=virtio,macaddr='9a:11:6d:ce:fe:2c' -net tap,vlan=0,ifname='t0-032051-g7gW',script='/home/autotest/client/tests/kvm/scripts/qemu-ifup-switch',downscript='no' -m 4096 -smp 2,cores=1,threads=1,sockets=2 -cpu qemu64,+sse2 -soundhw ac97 -vnc :1  -rtc-td-hack -M rhel5.5.0 -usbdevice tablet -no-kvm-pit-reinjection

2. check disks in guest
ls [vhs]d?
3.
  
Actual results:
only vda is listed

Expected results:


Additional info:
1. guest
rhel6-32

2. host
2.6.18-231.el5
Comment 2 RHEL Product and Program Management 2011-01-11 15:27:11 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2011-01-11 17:56:32 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 4 Kevin Wolf 2011-01-17 05:54:59 EST
I can reproduce this. I can't see problems if I choose consecutive index numbers. Can you confirm this? If so, I think it's not an important use case and we may close the bug.
Comment 5 Suqin Huang 2011-01-20 04:33:56 EST
try guest rhel6.64 on 2.6.18-238.el5 & kvm-83-224.el5

1. can boot up guest and get attached disks with index order

0, 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12

2. can not boot up guest with index order

0, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14
Comment 7 Kevin Wolf 2011-07-28 10:51:31 EDT
There's an easy workaround, won't fix the bug in RHEL 5 therefore.

Note You need to log in before you can comment on or make changes to this bug.