Bug 654200 - [ml_IN] Rendering with 0D30 and 0D31 breaking in ICU with all fonts
Summary: [ml_IN] Rendering with 0D30 and 0D31 breaking in ICU with all fonts
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: icu
Version: 14
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 529905 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-17 06:53 UTC by Ani Peter
Modified: 2016-08-01 01:31 UTC (History)
9 users (show)

Fixed In Version: icu-4.4.1-6.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-07 20:18:28 UTC
Type: ---


Attachments (Terms of Use)
Screen shot comparing wrong rendering in OOWRITER and correct rendering in GEDIT for 0D30 and 0D31. (124.78 KB, image/png)
2010-11-17 06:53 UTC, Ani Peter
no flags Details
after reverting patch (76.94 KB, image/png)
2010-11-17 11:05 UTC, Pravin Satpute
no flags Details
pages from vishwabharati april 2002 release (831.71 KB, application/pdf)
2010-11-18 06:27 UTC, Pravin Satpute
no flags Details
Screenshot showing Uniscribe with correct rendering with 0D30 and 0D31 (15.67 KB, image/jpeg)
2010-11-19 07:06 UTC, Ani Peter
no flags Details
Screen shot showing correct rendering in ICU in F14 testing repo (107.01 KB, image/png)
2010-11-26 11:52 UTC, Ani Peter
no flags Details
redering of u0d30 and u0d31 in fedora rawhide(f16) (84.38 KB, image/png)
2011-05-12 11:02 UTC, Pravin Satpute
no flags Details
PDF file exported to text ICU rendering in rawhide (10.64 KB, application/pdf)
2011-05-13 07:44 UTC, Ani Peter
no flags Details

Description Ani Peter 2010-11-17 06:53:32 UTC
Created attachment 461001 [details]
Screen shot comparing wrong rendering in OOWRITER and correct rendering in GEDIT for 0D30 and 0D31.

Description of problem:
F14 is having serious rendering issues in combinations with 0D30 and 0D31. These new issues is present in all Malayalam fonts including default smc-meera-font and Lohit Malayalam.
Screen shot comparing the wrong rendering in OOWRITER and correct rendering in GEDIT for the combinations is attached.

Version-Release number of selected component (if applicable):
openoffice.org-core-3.3.0-13.3.fc14
libicu-4.4.1-3.fc14 

Steps to reproduce:
1. Open oowriter.
2. Type following key combinations:
(i)  ക  + ്  +  ര  (0D15 + 0D4D + 0D30) or (Key k + Key d + key j)
(ii) ക  + ്  +  റ  (0D15 + 0D4D + 0D31) or (Key k + Key d + shift key j)
(iii) ന  + ്  +  റ (0D28 + 0D4D + 0D31) or (Key v + Key d + shift key j)
(iv) റ  + ്  +  റ (0D31 + 0D4D + 0D31) or (Key shift j + Key d + shift key j)


Actual results:
When you type above combinations in F14, the result you get now is:
(i)  ക  + ്  +  ര => ര്ക
(ii) ക  + ്  +  റ  => ര്ക
(iii) ന  + ്  +  റ => ര്ന
(iv) റ  + ്  +  റ => ര്‌റ

Expected results:
The expected result for the combinations are:
(i)  ക  + ്  +  ര => ക്ര
(ii) ക  + ്  +  റ  => ക്റ
(iii) ന  + ്  +  റ => ന്റ
(iv) റ  + ്  +  റ => റ്റ

Additional info:
Till F13, only Lohit Malayalam, Samyak Malayalam and Kalyani had problems, that too only with 0D30, rest all combinations and all fonts were perfect. Bug has been filed for the same against ICU: Bug #529905

(i) All consonants except 0D16, 0D1A, 0D20, 0D25, and 0D32, when combined with 0D30 (ര) gives new conjunct with the prebased glyph.
(ii) All consonants except 0D28 and 0D31, when combined with 0D31 (റ) results with just the key combination.

Comment 1 Caolan McNamara 2010-11-17 09:31:51 UTC
And how do we know what is right and what is wrong in these circumstances ? Is there formal specifications for these. How about e.g. their rendering under uniscribe ?

Comment 2 Pravin Satpute 2010-11-17 10:57:42 UTC
just done scratch build reverting patch http://bugs.icu-project.org/trac/changeset/26090/icu/trunk/source/layout/IndicReordering.cpp

http://koji.fedoraproject.org/koji/taskinfo?taskID=2605879

things working properly after reverting this patch, dunno what was basic intention behind the patch, Praveen and Ani can tell better, but removing this patch solve the thing

written in patch 
"The TDIL spec says that consonant + virama + RRA should produce a rakar in Malayalam.  However, // it seems that almost none of the fonts for Malayalam are set up to handle this.// So, we're going to force the issue here by using the rakar as defined with RA in most fonts. "
but dunno was there any problem previously?

Comment 3 Pravin Satpute 2010-11-17 11:05:24 UTC
Created attachment 461038 [details]
after reverting patch

Comment 4 Caolan McNamara 2010-11-17 11:48:39 UTC
That's great, so we have a plausible fix. Does anyone have a reference to the TDIL spec, I can only seem to find brief plans and notes on it.

Comment 5 Pravin Satpute 2010-11-18 06:27:55 UTC
Created attachment 461226 [details]
pages from vishwabharati april 2002 release

luckily i had a copy of Vishwabharati PDf, just exported relevant pages from it.

on page 31 they have given information regarding rakar, lakar looks like may be with patch it is implemented wrongly .

Comment 6 Caolan McNamara 2010-11-18 17:00:41 UTC
*** Bug 529905 has been marked as a duplicate of this bug. ***

Comment 7 Ani Peter 2010-11-19 07:06:37 UTC
Created attachment 461472 [details]
Screenshot showing Uniscribe with correct rendering with 0D30 and 0D31

The patch applied here was unwanted, and thats the reason it created the whole mess. Few years back, there was a request for this patch, but it was actually wrong and hence not applied in any rendering engine. It at all anywhere this was applied has been reverted. The actual and correct rendering is the result what we got after Pravin has reverted the patch. This rendering exists throughout all rendering engines. For reference, screen shot in Uniscribe attached. 

Caolon, I would really appreciate if you could revert the patch which will help things to work smoothly. Thanks to you guys for your help and understanding.

Comment 8 Caolan McNamara 2010-11-25 15:21:01 UTC
Filed this as http://bugs.icu-project.org/trac/ticket/8198

builds underway,

Comment 9 Fedora Update System 2010-11-25 15:35:28 UTC
icu-4.4.1-5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/icu-4.4.1-5.fc14

Comment 10 Fedora Update System 2010-11-26 01:13:57 UTC
icu-4.4.1-5.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update icu'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/icu-4.4.1-5.fc14

Comment 11 Ani Peter 2010-11-26 11:52:13 UTC
Created attachment 463066 [details]
Screen shot showing correct rendering in ICU in F14 testing repo

Tested icu from F14 testing repo. Working perfect. Have attached screen shots for icu with Meera (traditional script) and Lohit Malayalam (new script) fonts.

Thank you Caolan for all th help :)

Comment 12 Fedora Update System 2010-11-29 11:34:34 UTC
icu-4.4.1-6.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/icu-4.4.1-6.fc14

Comment 13 Fedora Update System 2010-12-07 20:18:17 UTC
icu-4.4.1-6.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Biju 2011-01-11 12:24:24 UTC
(In reply to comment #1)
> And how do we know what is right and what is wrong in these circumstances ? Is
> there formal specifications for these. 

Caolán,

If we redo Unicode, we should have followed rules from
http://www.malayalamresourcecentre.org/Mrc/literature/keralapaanineeyam/panineeyam.html
ie, symbols both for both 0D30 and 0D31 behave same, only difference it should
make is when displayed as full letter.
And use 0D3A when sound "t" in English words "Tea, tight" was indented.

http://unicode.org/charts/PDF/Unicode-6.0/U60-0D00.pdf
0D3A MALAYALAM LETTER TTTA
0D30 MALAYALAM LETTER RA
0D31 MALAYALAM LETTER RRA

But for now we have to do case by case.

Comment 15 Pravin Satpute 2011-05-12 11:02:51 UTC
Created attachment 498505 [details]
redering of u0d30 and u0d31 in fedora rawhide(f16)

just tested in rawhide its working fine 

libreoffice-writer-3.3.99.4-2.fc16.x86_64
libicu-4.6-2.fc16.x86_64

if there are particular test cases not working fine please provide them or report new bug, so we can test and start working on it

thanks

Comment 16 Ani Peter 2011-05-13 07:44:00 UTC
Created attachment 498713 [details]
PDF file exported to text ICU rendering in rawhide

I agree with Pravin's comment #15 and confirm that malayalam rendering works good in rawhide. Have exported the document to PDF and the same is attached for reference.
Thanks!


Note You need to log in before you can comment on or make changes to this bug.