Bug 65421 - X server crashes randomly when left idle (ATI Radeon Mobility M6)
X server crashes randomly when left idle (ATI Radeon Mobility M6)
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-23 13:56 EDT by Matthew Saltzman
Modified: 2007-04-18 12:42 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 05:16:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My current XF86Config-4 (3.73 KB, text/plain)
2002-05-25 16:41 EDT, Matthew Saltzman
no flags Details
XFree86.0.log from a normal startup. If any changes after crash, I'll post an update. (26.65 KB, text/plain)
2002-05-25 16:44 EDT, Matthew Saltzman
no flags Details
XFree86 log after a crash (22.30 KB, text/plain)
2002-08-11 15:10 EDT, Need Real Name
no flags Details
XFree86 Configuration file. DRI disabled. (3.64 KB, text/plain)
2002-08-11 15:11 EDT, Need Real Name
no flags Details

  None (edit)
Description Matthew Saltzman 2002-05-23 13:56:02 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.0rc2) Gecko/20020512

Description of problem:
If I leave the machine idle while logged in under X for some time (one hour or
several hours), I return to find myself back at the login screen).

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Runlevel 5, Gnome session manager, Gnome (Sawfish) WM.  Log in.
2. Walk away for some time (one hour to overnight).
3. Come back.
	

Actual Results:  Login screen is displayed.

Expected Results:  Should return to the same state you left (with screensaver
running or screen blanked).

Additional info:

(1) last command shows a normal logout at the time of the crash.
(2) log messages appear from gnome_name_server and gdm, but they appear to be
consequences of the crash.
(3) I went through all the screeen savers, and they all run without crashing X,
at least in demo mode and for short periods.
Comment 1 Matthew Saltzman 2002-05-23 14:00:14 EDT
I was running the XFree86-4.2-?? RPMs that you provided for RHL 7.2 and the
2.4.17 kernels in Rawhide at the time, and this never happened with those packages.
Comment 2 Matthew Saltzman 2002-05-23 15:33:59 EDT
Sorry, I should have mentioned:  Dell Latitude C610, BIOS A07.  I've been
running the BIOS since its release (4/12) but the problem only seems to have
started since upgrade to RHL 7.3 in early May.

There is a new BIOS A08 released yesterday.  I will try that.
Comment 3 Mike A. Harris 2002-05-24 17:43:56 EDT
If you disable DRI does it change anything?

Please attach your config file, log file and /var/log/messages from after
a crash.
Comment 4 Matthew Saltzman 2002-05-25 16:40:24 EDT
Is removing the Load "dri" line in XF86Config-4 enough to disable DRI?

The config file is attached.  From /var/log/messages:

May 22 20:44:31 paladin gnome-name-server[1761]: input condition is: 0x11, exiting
May 22 20:44:31 paladin gdm(pam_unix)[1588]: session closed for user mjs
May 22 20:44:31 paladin gdm[1588]: gdm_slave_xioerror_handler: Fatal X error -
Restarting :0
May 22 20:46:04 paladin gconfd (mjs-1771): GConf server is not in use, shutting
down.
May 22 20:46:04 paladin gconfd (mjs-1771): Exiting
Comment 5 Matthew Saltzman 2002-05-25 16:41:56 EDT
Created attachment 58527 [details]
My current XF86Config-4
Comment 6 Matthew Saltzman 2002-05-25 16:44:23 EDT
Created attachment 58528 [details]
XFree86.0.log from a normal startup.  If any changes after crash, I'll post an update.
Comment 7 Need Real Name 2002-05-29 00:32:00 EDT
I have the same problem.  I am using a AMD K6-2 processor with a NVidia Riva TNT
card.  The X-Server stays up for about two days and then crashes.  It has always
crashed while I was away from the computer, but that could be a coincidence.  I
will post my XFree86 log the next time it happens.
Comment 8 Matthew Saltzman 2002-06-18 19:58:06 EDT
An uptade: For several days,I have been trying starting in runlevel 3 in hopes
of catching something in the X log file.  So far the behavior has not recurred
in runlevel 3.  I don't know if that has anything to do with the runlevel or if
I've just been lucky, but there it is.  The crashes do occur in runlevel 5.
Comment 9 Need Real Name 2002-07-17 12:47:21 EDT
This doesn't just happen when the system is idle for me.  I can't find any
pattern to when it happens though.  If I'm running X-windows from a console, all
it says is "Segmentation Fault" when it crashes, and there is nothing about it
in /var/log/messages.
Comment 10 Need Real Name 2002-07-17 23:42:02 EDT
I've been running gdb on X, and I got a stack trace of a crash.  Perhaps this
might help.  I'll keep trying and see if it keep crashing in the same place.

Program received signal SIGSEGV, Segmentation fault.
0x080b5a1d in ProcPolyLine ()
(gdb) cont
Continuing.
         
Program received signal SIGABRT, Aborted.
0x400910a1 in kill () from /lib/libc.so.6
(gdb) bt
#0  0x400910a1 in kill () from /lib/libc.so.6
#1  0x40090e99 in raise () from /lib/libc.so.6
#2  0x40092364 in abort () from /lib/libc.so.6
#3  0x080da040 in GiveUp ()
#4  0x080db5c5 in FatalError ()
#5  0x08080487 in xf86SigHandler () 
#6  <signal handler called>
#7  0x080b5a1d in ProcPolyLine ()
#8  0x080b31e4 in Dispatch ()
#9  0x080c432b in main ()
#10 0x400801c4 in __libc_start_main () from /lib/libc.so.6
Comment 11 Mike A. Harris 2002-08-08 05:20:04 EDT
> Is removing the Load "dri" line in XF86Config-4 enough to disable DRI?

After doing so, you must restart X.
Comment 12 Need Real Name 2002-08-11 15:08:44 EDT
I have been running with DRI disabled for a while and it still crashes about the
same.  Seomtimes it crashes 3-4 times within in a few hours, sometimes it stays
up for days.  It seems to be crashing more often when I am using it than when
I'm not, but it definately crashes in either case.  I am attaching my
XFree86.0.log after a crash, and my XF86Config-4.

  - Vaughn
Comment 13 Need Real Name 2002-08-11 15:10:40 EDT
Created attachment 69944 [details]
XFree86 log after a crash
Comment 14 Need Real Name 2002-08-11 15:11:55 EDT
Created attachment 69945 [details]
XFree86 Configuration file.  DRI disabled.
Comment 15 Matthew Saltzman 2002-08-16 08:14:21 EDT
I'm the original reporter.  I have been running with dri disabled for a couple
of days now (in runlevel 5) with no crashes.  (Makes it hard to play TuxRacer,
though...)

(Sorry for the delayed reply, but I've been traveling.)
Comment 16 Need Real Name 2002-08-28 00:01:10 EDT
It appears my problem isn't isolated to XFree86.  I have had occasional kernel
oops's also (Unable to handle kernel NULL pointer dereference).  Two oopses
occurred with EIP at d_lookup when I was running 2.4.18-5.  The latest one had
EIP at page_referenced, which was after I upgraded to 2.4.18-10.  I ran
memtest86 for about 200 passes (more than 48 hours) without any errors.  I've
seen that there have been similar bugs reported for kernel Oopses with RedHat
7.3.  Is there anything I can do to help track down this problem?
Comment 17 Need Real Name 2002-08-31 12:39:57 EDT
I am now using kernel-2.4.9-34 from RedHat 7.2.  The X server crashes have still
been happening.  I haven't had any kernel oopses, but it has only been a couple
of days since I installed 2.4.9, and the oopses were rare (once every three
weeks or so).   I have switched to using gnome to see if this helps.
Comment 18 Matthew Saltzman 2002-08-31 14:49:17 EDT
> I have switched to using gnome to see if this helps.

If we are having the same problem, it won't.  I've been running GNOME all along.

BTW, I'm using the updated kernel kernel-2.4.18-10.  I still to see the problem
with DRI on, in Runlevel 5, with GNOME and Sawfish.  Turning DRI off or
switching to Runlevel 3 causes to problem to cease.
Comment 19 Need Real Name 2002-08-31 15:06:36 EDT
I have been running with DRI disabled for over a month and the problem happened
about the same.  I tried using runlevel 3 once and it still crashed, so I
switched back to runlevel 5.  I'll keep experimenting.
Comment 20 Need Real Name 2002-09-01 11:37:51 EDT
> If we are having the same problem, it won't.  I've been running GNOME all along.

Well, you were right.  It crashed again within 24 hours while I was away.  One
interesting thing is that that /var/log/messages showed that it had crashed
twice within about 10 minutes, so that means it crashed while it was at the
login screen!  I'm going to try using runlevel 3 again with DRI disabled.
Comment 21 Need Real Name 2002-09-03 23:33:10 EDT
I tried using runlevel 3.  The first time I switched to runlevel 3 from runlevel
5 and then ran startx, but it crashed after a while.  The next time I booted
into runlevel 3 and used startx, but it crashed again after about a day.  I'm
not sure what to try next.
Comment 22 Matthew Saltzman 2002-09-29 09:53:56 EDT
OK I'm a bit confused.  Mike are you still waiting for info from me, and if so,
what?

Thanks.
Comment 23 Bob Cochran 2002-10-11 00:05:07 EDT
This problem happens to me also on a Red Hat 8.0 system. I'm running with an ATI
Radeon 9000 Pro graphics card, on a desktop system I built myself. In my case,
the mysterious exits out of my logon account are supplemented by apparent X
freezeups. Pressing CTRL-ALT-Backspace won't "unfreeze" X and I have no option
but to reset the computer. I believe that either X or Ximian Evolution will
cause spontaneous system reboots because this happened to me yesterday while I
was in Evolution. I also wonder if the default screensavers in 8.0 are
contributing to the problem. 

My system details are: 2.8 Ghz Pentium 4, Asus P4T533 motherboard updated to the
latest BIOS version, 512 Mb RIMM4200 RAM. There are two (2) Western Digital
WD1200JB hard drives, each 120 Gb with 8 Mb cache, configured as software RAID
devices /md0 and md1. The spontaneous system reboots and forced resets trigger
re-syncing of the RAID arrays which then tends to deny me the use of the system
for many hours since this process eats up a lot of CPU time.

Bob Cochran
Comment 24 Matthew Saltzman 2002-10-24 18:29:17 EDT
OK Since the upgrade to kernel-2.4.18-17.7.x, I have left the machine overnight
in runlevel 5 several times and have not had a crash.  Not sure what that means,
but for now I have converted back to runlevel 5 and will notify if I have any
more problems.

Was something patched that might affect this?
Comment 25 Matthew Saltzman 2002-10-25 08:56:19 EDT
Spoke too soon.  It crashed last night as before.

I have no idea if this is relevant, but I was playing with the gnome screen
saver panel, and invoking various sequences of demos will freeze the demo pane
in the panel.  Cynosure seems to be involved in all of the hangup sequences,
though it's not always the one that hangs.

I will now run with screensaver off for a while.
Comment 26 Matthew Saltzman 2002-11-06 10:15:11 EST
Another update:  A few days of running 7.3 with screensaver off produced no crashes.

On 11/1, I upgraded to RH8.0.  So far, no crashes (screensavers are running
however they are configured on installation).  Different mix of screensavers? 
Some other relevant change?
Comment 27 Michael A. Peters 2002-11-13 00:11:33 EST
I've been having crashes in Red Hat 8.0 using gnome.
Either the computer completely freezes (can't even ping it, ctrl-alt-F2 don't
get me a console- etc.)

Once it didn't crash- but dumped me into console (I boot to runlevel 3)

When I run KDE the machine NEVER crashes.
Run Gnome- it happens within 12 hours.

900MHz Athlon, VooDoo3 agp card.
I don't remember who made the mobo.

This box was fine with gnome in RH 7.2
Comment 28 Mike A. Harris 2002-12-15 05:13:48 EST
mpeters) This bug report is concerning an ATI Radeon Mobility, so it is
unlikely that it is at all related to a 3Dfx Voodoo card.  It also is definitely
not a GNOME or KDE bug.  If you get a crash, it is either an X server/driver
bug, a kernel bug, or a hardware issue.  It is never ever a software issue.
Comment 29 Mike A. Harris 2002-12-15 05:16:58 EST
Using Red Hat Linux 8.0, completely up2date, including the latest
kernel erratum, you should not observe any screensaver related lockups or
crashes.  I believe all screensaver related crash problems people have
experienced are now fixed in our current erratum set for RHL 8.0.  I've
asked everyone who has reported any screensaver related problems in the
past to test the latest stuff, and have received back no problem reports
to date.  I'm closing this issue as resolved in Red Hat Linux 8.0 kernel
ERRATA.

If you do happen to use 8.0+errata, and still encounter problems for some
reason, please open a fresh bug report and detail it there.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.