Bug 654236 - 'Send F8' is unavailable when installing a win2k3 or winxp guest
'Send F8' is unavailable when installing a win2k3 or winxp guest
Status: CLOSED DUPLICATE of bug 643317
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
Unspecified Unspecified
high Severity medium
: rc
: ---
Assigned To: Gerd Hoffmann
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier2
  Show dependency treegraph
 
Reported: 2010-11-17 04:44 EST by Qunfang Zhang
Modified: 2010-12-01 06:38 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-01 06:38:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qunfang Zhang 2010-11-17 04:44:19 EST
Description of problem:
When installing win2k3 or winxp guest, there's a stage need to Press F8 to agree and proceed. But after pressing F8, and select 'Send F8', there's no response to go ahead.
The only method to continue installing is input "sendkey f8" command in qemu monitor.

Version-Release number of selected component (if applicable):
kvm-83-207.el5
kernel-2.6.18-229.el5

How reproducible:
Always

Steps to Reproduce:
1.Install a win2k3 or winxp guest.
CLI:
/usr/libexec/qemu-kvm -m 2G -smp 2 -cpu qemu64,+sse2 -drive file=win2k3-64-virtio-backup.raw,media=disk,if=virtio,boot=on,cache=none,werror=stop -net nic,model=virtio,vlan=0,macaddr=00:10:16:30:43:10 -net tap,vlan=0,script=/etc/qemu-ifup0  -uuid 9034a298-f04f-47eb-bda5-5219f9e7ed2d  -monitor stdio -vnc :1 -boot dc  -usbdevice tablet -no-hpet -rtc-td-hack -no-kvm-pit-reinjection -startdate now -fda /usr/share/virtio-win/virtio-drivers-1.0.0-45801.vfd -cdrom en_win_srv_2003_r2_enterprise_x64_with_sp2_cd1_X13-06188.iso  -name 43-win2k3-64

2.There's a stage requiring to Press F8 to agree and go ahead.
3.Press "F8" and select "Send F8"
  
Actual results:
No response after select "Send F8".

Expected results:
F8 can be select and could continue installing.

Additional info:
Comment 1 Gerd Hoffmann 2010-12-01 03:13:51 EST
Can you retest with kvm-83-218.el5 please?
Comment 2 Qunfang Zhang 2010-12-01 04:04:07 EST
(In reply to comment #1)
> Can you retest with kvm-83-218.el5 please?

Re-test with kvm-83-219.el5 with the same steps in Comment 0, installing winxp, win2k3, and this issue does not exist.
Comment 3 Gerd Hoffmann 2010-12-01 06:38:33 EST
Good.

*** This bug has been marked as a duplicate of bug 643317 ***

Note You need to log in before you can comment on or make changes to this bug.