Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 654271 - Search for 'slow' delivers visitor to /show_bug.cgi?id=slow
Summary: Search for 'slow' delivers visitor to /show_bug.cgi?id=slow
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Bugzilla
Classification: Community
Component: Query/Bug List
Version: 3.6
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: PnT DevOps Devs
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-17 11:21 UTC by Thomas Spear
Modified: 2013-06-24 01:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-12-16 12:08:10 UTC


Attachments (Terms of Use)

Description Thomas Spear 2010-11-17 11:21:39 UTC
Description of problem:
On bugzilla.redhat.com, in the top search box, typing 'slow' without the quotes then clicking the search button delivers a visitor to a single bug with the search string (slow) as the bug id in the URL

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Go to http://bugzilla.redhat.com
2. In the top search box, in the navigation menu of every page, type "slow" without quotes.
3. Click Search
  
Actual results:
User delivered to http://bugzilla.redhat.com/show_bug.cgi?id=slow

Expected results:
User delivered to search results page for bugs containing the word "slow" in them.

Additional info:
I wasn't aware that having a non-numeric bug id would even work...

Comment 1 Noura El hawary 2010-12-16 12:08:10 UTC
Hi Thomas,

This is not a bug, basically the search box that appears in every page searches for bug ids or bug aliases and we can not change that because this is a standard behavior ,, so basically it is taking you to the bug that has "slow" in the alias,, however if you wanted to search for bugs that contains the word "slow" you can use the quicksearch feature, if you go to the home page of bugzilla, there is quicksearch section where you can type the text you want and relate it to any field in the bug reports for example to search for summaries that contains the word "slow" you would enter this:

[slow


there is a help page that explains more about the quicksearch : https://bugzilla.redhat.com/page.cgi?id=quicksearch.html


also if you want to see this quicksearch everywhere you can install the quicksearch plugin, there is a link for that in the home page..

I hope this will help.

Cheers,
Noura

Comment 2 Thomas Spear 2010-12-16 12:34:01 UTC
What would happen if a second bug were to get the slow alias? Would the new bug override the old (or vice versa)? Would a list then appear when searching as I did? Would the old bug lose the alias?

Comment 3 Thomas Spear 2010-12-16 12:35:28 UTC
Never mind, just found out, bugzilla won't allow the slow alias for any other bug once it is assigned, until it is unassigned from the original bug.


Note You need to log in before you can comment on or make changes to this bug.