Bug 6543 - Random Apache crash with Dual Processors
Random Apache crash with Dual Processors
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Preston Brown
www.ksl.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-30 14:38 EDT by andrew.bunker
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-12-15 16:41:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description andrew.bunker 1999-10-30 14:38:27 EDT
We are having a problem with Apache (1.3.9) crashing at
random intervals using Red Hat 6.1 (Kernel 2.2.1-20smp) with
dual processors.  Apache will crash anywhere from once to 20
times a day.  Sometimes just the parent Apache process dies
or locks up, and sometimes all the httpd processes die.
There is no pattern.  There do not seem to be any clues or
anomolous messages in the Apache or system log files.
Everything else seems to work just fine (But then again we
are not doing much else with the system).

Our system consists of an ASUS P2B-DS Motherboard with dual
Intel PII-400 cpu's with onboard Adapted AIC-7890AB SCSI
Controller, and two Intel Etherexpress Pro 10/100 Ethernet
cards.  I've tried reinstalling the OS (Both Red Hat 6.0 and
6.1), reinstalling and recompiling Apache (1.3.6 and 1.3.9
with PHP), and checking every hardware and software setting
and nothing seems to stop the random crashing.  The strange
thing is that Apache seems to crash more frequently in the
middle of the night when there is little or no traffic on
our site.  It almost seems that the smaller the http load,
the more frequently it crashes.  I finally solved the
problem by removing one of the PII-400 cpu's from the
motherboard.  Is there something wrong with the SMP Kernel?
Comment 1 Preston Brown 1999-11-02 10:55:59 EST
Doug, can you offer any opinions or insights into this one?
Comment 2 Doug Ledford 1999-11-03 02:47:59 EST
With the second processor installed, start apace, then run strace -p
<pid of parent apache process> and capture the output of that command
to disk.  Try to do this at night when apache is likely to die.  Wait
for it to die, then send the last few hundred lines of that output
here.  Note: if apache takes very long to die, this could be a *large*
file.  You may need to stop and restart the strace program a few
times, truncating the output file each time to keep it from getting
too large.
Comment 3 Preston Brown 1999-12-15 16:41:59 EST
closed due to lack of feedback and no other reports of similar nature.

Note You need to log in before you can comment on or make changes to this bug.