Bug 654417 - Changing my email address is too difficult and the help could be improved
Summary: Changing my email address is too difficult and the help could be improved
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Bugzilla
Classification: Community
Component: User Accounts
Version: 3.4
Hardware: Unspecified
OS: Unspecified
low
medium vote
Target Milestone: ---
Assignee: Simon Green
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-17 20:08 UTC by Jim Wright
Modified: 2014-10-12 22:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-05-01 03:47:22 UTC


Attachments (Terms of Use)

Description Jim Wright 2010-11-17 20:08:02 UTC
Description of problem:

I have wasted *lots* of time trying. I am getting stressed and thinking maybe I should not come back here. I was actually thinking of reporting some issues with Fedora 14 but have run out of enthusiasm for today at least.

Version-Release number of selected component (if applicable):

Following the Help link I see 3.4.3 Release. Can't see it closer than that.

How reproducible:

Steps to Reproduce:
1. Stumble across a page that allows me to submit a new email address. Yippee! That's one of the things that was stressing me out last time time I came here.
2. Receive email to my old address 1m21s later. By some good fortune it still works and I can click the download button in gmail even though I am not sure what my password is for the old email account. Hopefully the company that bought the company that bought the original provider will keep it working forever but since I need to enter the correct address when I log in, I really would like to change it to my current address. Wait for email to my new address...
3. Do what I was planning to do in bugzilla. Try and get fc14 working after upgrade issues, go to work. look after the kids, stack overload...
4 2 days later? Ah there it is. I completely forgot. It took 20 minutes but who said email is real time? Follow the confirmation link - it's stale
5 OK, where is that page where I can change it. Preferences - Email or Preferences - Name and password. I feel sure that it was the latter but cannot see it. Eventually find the help. Enter current password again expecting the problem will be solved. No! 
  
Actual results:

I don't know why I cannot find this damn new email address field. 

Expected results:

If I cannot find it and there is a reason then please explain preferably on the page why it is not there. Failing that in the help. Maybe you have some security concerns and don't mind a bit of obscurity if it slows down the crackers? I mind!

Additional info:

There was a 19 minute delay here delivering to my new email service provider:

Received: from mx1-phx2.redhat.com (mx1-phx2.redhat.com [209.132.183.26])
	by in.smtp.cz (Postfix) with ESMTP id 44C04A694E
	for <my new address deleted>; Mon, 15 Nov 2010 23:07:14 +0100 (CET)
Received: from bzweb01.app.bz.hst.phx2.redhat.com (bzweb01.app.bz.hst.phx2.redhat.com [10.5.117.16])
	by mx1-phx2.redhat.com (8.13.8/8.13.8) with ESMTP id oAFLmAxb026786
	for <my new address deleted>; Mon, 15 Nov 2010 16:48:10 -0500

but not here when delivering to my old email service provider:

Received: from mx1-phx2.redhat.com ([209.132.183.26])
 by port.iol.cz with ESMTP; Mon, 15 Nov 2010 22:48:12 +0100
Received: from bzweb01.app.bz.hst.phx2.redhat.com
 (bzweb01.app.bz.hst.phx2.redhat.com [10.5.117.16])
	by mx1-phx2.redhat.com (8.13.8/8.13.8) with ESMTP id oAFLm9Sa026783	for
 <my old address deleted>; Mon, 15 Nov 2010 16:48:10 -0500

Comment 1 Jim Wright 2010-12-05 15:31:35 UTC
I have successfully changed my email address. It appears that the field to change email address disappears from the "Name and Password" tab for some time after each attempt, whether successful or not?

I suggest adding the above detail to the page or the help which currently just says:

"If you attempt to change your email address, a confirmation email is sent to both the old and new addresses, with a link to use to confirm the change. This helps to prevent account hijacking."

So what is missing is an explanation of why the field may be missing. Sorry I am not in a position to provide suggested text. Possibly no one is, which would be an indication that the behaviour should be changed.

Comment 2 Simon Green 2012-05-01 03:47:22 UTC
The Red Hat Bugzilla team apologises for the problems you experienced when trying to change your e-mail address in Bugzilla. As you have mentioned, the correct place to do so is Preferences -> Name and Password.


Note You need to log in before you can comment on or make changes to this bug.