Bug 65450 - windowmaker cannot be launched from xdm
Summary: windowmaker cannot be launched from xdm
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: wmakerconf   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-24 12:18 UTC by Need Real Name
Modified: 2007-04-18 16:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-24 16:47:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-05-24 12:18:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
when choosing windowmaker from the login panel gnome is started instead

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
when choosing windowmaker from the login panel gnome is started instead

Actual Results:  Gnome started

Expected Results:  Windowmaker to be started

Additional info:

the file /etc/X11/xdm/Xsession is errorneous. Attached is a diff to fix the bug.
-----------------------------
82d81
< echo >&2 Environment choosen is $1
98,100d96
<        ;;
<    wmaker)
<        exec -l $SHELL -c "/usr/share/apps/switchdesk/Xclients.windowmaker"

Comment 1 Phil Copeland 2002-05-24 15:32:48 UTC
Mike, isn't /etc/X11/xdm/Xsession part of xinitrc?
any chance of this two liner being dropped in? Or am I expected to munch
Xsession on install of WindowMaker?

Phil
=--=

Comment 2 Peter van Egdom 2002-07-14 20:57:56 UTC
Selecting "Window Maker" from GDM still starts GNOME instead of Window Maker in
the latest beta version of Red Hat Linux (Red Hat Linux release 7.3.92 (Limbo)).



Comment 3 Peter van Egdom 2002-07-31 18:11:00 UTC
This bug also happens in the latest Red Hat Linux beta (Limbo 7.3.93)

Comment 4 Peter van Egdom 2002-08-21 18:46:48 UTC
Seems to be fixed in the latest Red Hat Linux ('null').

Thanks!


Note You need to log in before you can comment on or make changes to this bug.