Bug 65454 - remote emails rejected by check_rcpt rule-set despite valid entries in mailertable
remote emails rejected by check_rcpt rule-set despite valid entries in mailer...
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: sendmail (Show other bugs)
7.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Florian La Roche
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-24 09:54 EDT by tim
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-05 10:51:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tim 2002-05-24 09:54:40 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.0.0; Linux) 
 
Description of problem: 
/etc/mail/mailertable entries are recognised for local email. However, when email is 
received from a remote host the 'check_rcpt' rule-set is triggered. This rule-set does 
not check against any mailertable entries and therefore does not regard the domains 
listed in mailertable as local. A relaying denied error is then produced. 
 
Version-Release number of selected component (if applicable): 
8.11.6-3 
 
How reproducible: 
Always 
 
Steps to Reproduce: 
1. Configure a mailertable entry (virtual.com procmail:/etc/procmail.rc) that passes 
mail for virtual.com to procmail (in mail filter mode) for delivery. 
 
2. Verify that sendmail resolves this correctly as follows: 
 sendmail -bt 
 > 3,0 someone@virtual.com 
 
3. From the local machine send mail to someone@virtual.com and confirm via the maillog 
that the procmail recipe specified in mailertable was correctly selected as the 
delivery agent. It is not necessary to see the mail all the way through to delivery, 
however, with a correctly configured procmail.rc the username can be picked up as an 
argument to the procmail recipe and mail can manipulated before delivery to a 'virtual' 
user. 
 
4. From a remote machine send mail to the machine configured above (using mail -v).  
  
 
Actual Results:  It can be seen that the RCPT message results in a rejection. Examining 
the sendmail logs indicates the rejection originates from the check_rcpt rule-set. 
 
Expected Results:  The check_rcpt rule-set should have recognised the virtual.com 
domain as being local because there is a mailertable entry for it present. 
 
Additional info: 
 
Within the Basic_check_rcpt rule-set... 
 
# authenticated by a trusted mechanism? 
R$*                     $: $1 $| $&{auth_type} 
R$* $|                  $: $1 
R$* $| $={TrustAuthMech}        $# RELAYAUTH 
R$* $| $*               $: $1 
# anything terminating locally is ok 
R$+ < @ $=w >           $@ RELAYTO 
R$+ < @ $* $=R >        $@ RELAYTO 
R$+ < @ $+ >            $: $>LookUpDomain <$2> <?> <$1 < @ $2 >> <+To> 
R<RELAY> $*             $@ RELAYTO 
R<$*> <$*>              $: $2 
 
The following additional lines resolve the problem... 
 
R$+ < @ $* >            $: <>$( mailertable $1 $) < @ $2 > $| 
R<>$*                   $@ RELAYTO
Comment 1 Florian La Roche 2003-05-05 10:51:08 EDT
This problem should be corrected by the last sendmail errata that has
gone out.

greetings,

Florian La Roche


Note You need to log in before you can comment on or make changes to this bug.