Bug 654560 - clang 2.7 can not compile hello.cc
clang 2.7 can not compile hello.cc
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: llvm (Show other bugs)
13
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Bryan O'Sullivan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-18 04:14 EST by Filip Miletic
Modified: 2010-12-13 15:04 EST (History)
5 users (show)

See Also:
Fixed In Version: llvm-2.8-5.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-13 14:59:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Filip Miletic 2010-11-18 04:14:42 EST
Description of problem:
The clang 2.7 distributed with Fedora 13 is unusable.  
Can not compile hello world.


Version-Release number of selected component (if applicable):
clang-2.7-11.f13

How reproducible:


Steps to Reproduce:
1. See below.
  
Actual results:
Compiler dies with sigsegv.

Expected results:
Compiler does anything else but crash.

Additional info:


filip@kravica:~/tmp/clang-test
$ cat hello.cc

#include <iostream>


int main() {
  std::cout << "Hello world" << std::endl;
  return 0;
}
filip@kravica:~/tmp/clang-test
$ clang++ hello.cc
In file included from hello.cc:2:
/usr/include/c++/4.4.4/iostream:38:10: fatal error: 'bits/c++config.h' file not found
#include <bits/c++config.h>
         ^
0  libLLVM-2.7.so 0x00fb83c9
1  libLLVM-2.7.so 0x00fb8a66
2                 0x0049f400 __kernel_sigreturn + 0
3  clang          0x0853f55c
4  clang          0x0853fa03
5  clang          0x08373b9a
6  clang          0x08374840
7  clang          0x08375308
8  clang          0x083b73ac
9  clang          0x083b7fa0
10 clang          0x085efef4
11 clang          0x085bfb66
12 clang          0x085d9592
13 clang          0x085dbee7
14 clang          0x085dcc43
15 clang          0x085cbd87
16 clang          0x085f867c
17 clang          0x085f968e
18 clang          0x085f99e1
19 clang          0x085d424d
20 clang          0x085c47e2
21 clang          0x085c4af9
22 clang          0x0827238c
23 clang          0x08077fea
24 clang          0x080780f8
25 clang          0x080660c2
26 clang          0x0805788b
27 clang          0x0805b629 main + 1817
28 libc.so.6      0x0027bcc6 __libc_start_main + 230
29 clang          0x08055d31
Stack dump:
0.	Program arguments: /usr/bin/clang -cc1 -triple i386-redhat-linux-gnu -S -disable-free -disable-llvm-verifier -main-file-name hello.cc -mrelocation-model static -mdisable-fp-elim -mconstructor-aliases -target-cpu pentium4 -resource-dir /usr/lib/clang/1.1 -fmessage-length 127 -fexceptions -fgnu-runtime -fdiagnostics-show-option -fcolor-diagnostics -o /tmp/cc-NnKXQ8.s -x c++ hello.cc 
1.	/usr/include/c++/4.4.4/ostream:380:7: current parser token 'basic_ostream'
2.	/usr/include/c++/4.4.4/ostream:376:5: parsing struct/union/class body 'basic_ostream::'
clang: error: compiler command failed due to signal 11 (use -v to see invocation)
filip@kravica:~/tmp/clang-test
$
Comment 1 Hans de Goede 2010-11-21 04:45:40 EST
clanbomber is not the correct component for clang bugs, changing component to llvm.
Comment 2 Michel Alexandre Salim 2010-11-27 09:32:55 EST
Right; clang (and clang++) currently depends on the respective GCC component (gcc and g++) for linking and for headers.

I'm building a new 2.8 update (2.8-5) that rectifies this issue by pulling in gcc-c++.
Comment 3 Fedora Update System 2010-11-27 12:36:59 EST
llvm-2.8-5.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/llvm-2.8-5.fc13
Comment 4 Fedora Update System 2010-11-27 12:37:05 EST
llvm-2.8-5.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/llvm-2.8-5.fc14
Comment 5 Fedora Update System 2010-11-27 18:33:35 EST
llvm-2.8-5.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update llvm'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/llvm-2.8-5.fc13
Comment 6 Fedora Update System 2010-12-13 14:59:04 EST
llvm-2.8-5.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2010-12-13 15:04:03 EST
llvm-2.8-5.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.