Bug 6546 - Kernel Panic... unable to mount root fs...
Kernel Panic... unable to mount root fs...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-30 17:44 EDT by gamercier
Modified: 2015-01-07 18:39 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-08 21:25:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description gamercier 1999-10-30 17:44:08 EDT
Hi!

I have a dual Pentium II (Xeon) box running Win NT v. 4 and
Red Hat Linux version 6.0. Booting is controlled
by the Win NT OS Loader (I had used Bootpar to setup
the proper option within the OS Loader to bring Lilo and
boot linux off /boot partition.) I have a hard drive
split into several partitions:

C: DOS1 FAT /dos   2047MB
Linux   /boot        24MB
D: DOS2 FAT /dos2  3004MB
Linux  /swap        133MB
Linux  /home       4001MB
Linux  /usr/local  2000MB
Linux  /           6150MB


I went ahead and bought Red Hat Linux v. 6.1 and use
the upgrade option with the new image boot disk:
Red Hat 6.1 boot-RHEA-1999:044.img

I only followed the upgrade option.

After rebooting, I got the Lilo prompt (not the
OS Loader prompt as I used to get), and when I
request the "linux" or "linux-up" options I get the
following Kernel panic message:

Kernel Panic: VFS: Unable to mount root fs on 08:0a

Any solutions?

Unfortunately, I don't have a rescue disk (looks like
I lost the one for 6.0! Blah! and the installation
never asked for building one for 6.1) Help!

I can pick the option "dos" under Lilo and it will
bring up Win NT OS Loader. This allows me to load NT,
but if I pick the linux option it hangs (this is no
surprise because I have not used bootpar to bring up-to-date
the NT loader.)

Any solutions to the problem of mounting the root fs?

I've tried doing a new upgrade installation with the
original boot disket. This made no difference.

Thanks!
Comment 1 Jay Turner 2000-02-08 21:25:59 EST
You can use the 6.1 CDROM to get into rescue mode without having to use a boot
disk.  This is a new feature in the 6.1 installer, as with previous installers,
the user had to have the boot disk made during the installation as well as a
rescue.img diskette.
Just throw the CDROM into the drive and type "linux rescue" at the boot prompt.
This will drop you into a bash shell where you should be able to rerun lilo to
determine why you are getting a kernel panic as a result of not finding the root
partition.

Reopen this bug if you continue to have problems.

Note You need to log in before you can comment on or make changes to this bug.