Bug 654628 - [abrt] firefox-4.0-0.5b7.fc15: incompatibility with libnotify (e.g., when download of largish file) [@ notify_notification_finalize]
[abrt] firefox-4.0-0.5b7.fc15: incompatibility with libnotify (e.g., when dow...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libnotify (Show other bugs)
rawhide
x86_64 Unspecified
low Severity high
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
abrt_hash:e2890b1f1cd1323238d62ae92b9...
: Triaged
: 654920 662111 (view as bug list)
Depends On:
Blocks: F15Alpha/F15AlphaBlocker
  Show dependency treegraph
 
Reported: 2010-11-18 08:25 EST by Peter Hjalmarsson
Modified: 2013-03-05 23:05 EST (History)
25 users (show)

See Also:
Fixed In Version: libnotify-0.7.0-2.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-01-03 21:06:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (65.74 KB, text/plain)
2010-11-18 08:25 EST, Peter Hjalmarsson
no flags Details
Part of the thread where crash happened (1.16 KB, text/plain)
2010-11-27 07:31 EST, Matěj Cepl
no flags Details
another backtrace (70.65 KB, text/plain)
2010-12-11 13:54 EST, Nicolas Mailhot
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 633829 None None None Never
Mozilla Foundation 622696 None None None Never

  None (edit)
Description Peter Hjalmarsson 2010-11-18 08:25:40 EST
abrt version: 1.1.14
architecture: x86_64
Attached file: backtrace
cmdline: /usr/lib64/firefox-4/firefox -UILocale sv-SE
component: firefox
executable: /usr/lib64/firefox-4/firefox
kernel: 2.6.36-4.fc15.x86_64
package: firefox-4.0-0.5b7.fc15
reason: Process /usr/lib64/firefox-4/firefox was killed by signal 11 (SIGSEGV)
release: Fedora release 15 (Rawhide)
time: 1290086442
uid: 500

How to reproduce
-----
I had my firefx running with a couple of tabs. CHoosed from one of them to download and open a PDF in evince.
When I was about to close evince, the computer became nearly non-responsive, I could switch between windows, but the content did not draw. 
The three windows disappered (i.e. firefox main windows, downloads and evince) and this bugreport appered.
Comment 1 Peter Hjalmarsson 2010-11-18 08:25:43 EST
Created attachment 461291 [details]
File: backtrace
Comment 2 Martin Kho 2010-11-19 15:37:19 EST
Package: firefox-4.0-0.5b7.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. Go to fedora nightly-composes logs [1].
2. Download a log file
3. Wait a second ... crash :-)

[1] http://alt.fedoraproject.org/pub/alt/nightly-composes/kde/logs/
Comment 3 Adam Williamson 2010-11-26 13:02:04 EST
Package: firefox-4.0-0.5b7.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. Download a file
2. Wait
3.


Comment
-----
Firefox crashes 100% reproducibly every time I download a file. Download a file, wait 5 seconds, it crashes.
Comment 4 Martin Kho 2010-11-26 13:36:02 EST
Hi,

Just tried what I did in comment #2... but this time Firefox didn't crash, huh? Today's updates installed.

Martin Kho

firefox-4.0-0.5b7.fc15.x86_64
xulrunner-2.0-0.6b7.fc15.x86_64
Comment 5 Adam Williamson 2010-11-26 15:28:03 EST
Proposing this as an F15 Alpha blocker:

"It must be possible to run the default web browser and a terminal application from the default desktop environment. The web browser must be able to download files, load extensions, and log into FAS"

okay, it can download files, but it shouldn't crash immediately afterwards.
Comment 6 Martin Kho 2010-11-26 15:46:11 EST
Hi,

@Adam: True Firefox downloaded the file correctly. But it also didn't crash after 5 seconds. It didn't even after more than an hour :-)

I have no idea why or what 'cured' the crash for me.

Martin Kho
Comment 7 Adam Williamson 2010-11-26 15:54:53 EST
it's been crashing consistently every time I download a file for several days, now, for me.
Comment 8 Martin Kho 2010-11-26 16:21:54 EST
Hi,

Now I tried with a some what bigger file [1] and yes it crashed ;-(

So it's an F15 Alpha blocker :-)

Martin Kho



[1] ftp://alviss.et.tudelft.nl/pub/fedora/linux/development/rawhide/x86_64/os/Packages/389-admin-1.1.13-1.fc15.x86_64.rpm (334 KB).
Comment 9 Matěj Cepl 2010-11-27 07:28:15 EST
Package: firefox-4.0-0.5b7.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1.just browsing through rhn.redhat.com I am not aware of anything special
2.
3.
Comment 10 Matěj Cepl 2010-11-27 07:31:12 EST
(In reply to comment #9)
> 1.just browsing through rhn.redhat.com I am not aware of anything special

Actually, yes it could be it ... I was downloading 185M ISO image with RHEL-6.
Comment 11 Matěj Cepl 2010-11-27 07:31:27 EST
Created attachment 463232 [details]
Part of the thread where crash happened
Comment 12 Matěj Cepl 2010-11-27 07:54:35 EST
I have no idea, how to search for duplicates on this .. both names of functions are so generic that I get hundreds of unrelated bugs.
Comment 13 Peter Hjalmarsson 2010-11-27 10:25:46 EST
Package: firefox-4.0-0.5b7.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. Start firefox
2. Browse around in a couple of tabs
3. Close it and choose to save tabs


Comment
-----
This happends every time but abrt picks it up as a different crash every time, so sorry if I have reported this before and does not just remember.
Comment 14 Stephen 2010-11-27 10:32:14 EST
Package: firefox-4.0-0.5b7.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. Downloaded a file
2. Right Clicked on Downloaded file in Download window to access the download directory
3.
Comment 15 Adam Williamson 2010-11-27 14:04:18 EST
matej: abrt's own dupe detection seems to be doing a decent job, judging by the amount of CCs.
Comment 16 John Reiser 2010-11-27 16:26:56 EST
Package: firefox-4.0-0.5b7.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1.close X11 window after visiting bugzilla #653905  (refered by google search)
2.
3.
Comment 17 Shawn Starr 2010-11-28 11:44:45 EST
Package: firefox-4.0-0.5b7.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. Go to websites with external videos
2. When videos load in external app (mplayer for example) firefox dies
Comment 18 Matěj Cepl 2010-11-29 02:56:47 EST
Package: firefox-4.0-0.5b7.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1.just browsing ... at this moment my active tab was on http://sourceforge.net/projects/supybot/, but I am not sure how much that matters, the crash seems to be somewhere in Gtk
2.
3.


Comment
-----
There isn't a complete set of symbols in the backtrace, but I think the relevant thread should be covered.
Comment 19 Matěj Cepl 2010-11-29 02:57:47 EST
(In reply to comment #18)
> Package: firefox-4.0-0.5b7.fc15
> Architecture: x86_64
> OS Release: Fedora release 15 (Rawhide)
> 
> 
> How to reproduce
> -----
> 1.just browsing ... at this moment my active tab was on
> http://sourceforge.net/projects/supybot/, but I am not sure how much that
> matters, the crash seems to be somewhere in Gtk
> 2.
> 3.
> 
> 
> Comment
> -----
> There isn't a complete set of symbols in the backtrace, but I think the
> relevant thread should be covered.

Oh yes, I may be downloading supybot in the background.
Comment 20 Martin Kho 2010-12-02 06:05:33 EST
Hi,

FYI: I've tried Firefox 8pre nightly build [1]. It doesn't crash after downloading a large file.

Martin Kho 

[1] http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-trunk/
Comment 21 Jaekyun Lee 2010-12-02 08:59:57 EST
Package: firefox-4.0-0.5b7.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
it crashed during input korean,
Comment 22 dominique 2010-12-02 11:56:01 EST
Package: firefox-4.0-0.5b7.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1.I open firefox
2.after a variable time firefox crash
3.
Comment 23 dominique 2010-12-02 12:05:07 EST
(In reply to comment #22)
> Package: firefox-4.0-0.5b7.fc15
> Architecture: x86_64
> OS Release: Fedora release 15 (Rawhide)
> 
> 
> How to reproduce
> -----
> 1.I open firefox
> 2.after a variable time firefox crash
> 3.

Just one precision:
firefox crash when I download a file (on kde-look.org or on koji...)
Comment 24 Adam Williamson 2010-12-02 12:13:47 EST
martin: that doesn't necessarily prove anything, as the Fedora build is somewhat different to upstream; there can be bugs in the Fedora build that aren't in upstream. but we'll get b8 in Rawhide when it lands, of course.
Comment 25 Martin Kho 2010-12-02 13:06:53 EST
Hi,

@adam: thanks for the info.

Further I made two observations:

1. I observed (after Daniel Walsh pointed me at it) that all downloaded files were created with the context:

"unconfined_u:object_r:user_tmp_t:s0"

They have to be:
"unconfined_u:object_r:user_home_t:s0"
(at least this is what I get after running restorecon -R ~/)

2. Running Firefox as root, download a large file, it didn't crash. Btw. The downloaded file also had the context "unconfined_u:object_r:user_tmp_t:s0".


May be these observations are relevant.

Martin Kho
Comment 26 Martin Kho 2010-12-02 14:05:51 EST
Hi,

And a third observation:

a. When I open a pdf [e.g. see 1] - in my case - in okular (KDE pdf viewer) the file will be 'saved' in /tmp and Firefox doesn't crash. The pdf is directed to okular.

b. When I save the same pdf file (in ~/Downloads) Firefox crashes.

Martin Kho


[1] http://projects.ischool.washington.edu/mcdonald/courses/insc598_wi04/papers/wk04/Engestrom.ATIntro.pdf
Comment 27 Martin Kho 2010-12-02 14:15:51 EST
Hi,

Third observation is not correct, sorry.:-( After opening some more pdf's Firefox started crashing.

Martin Kho
Comment 28 Christopher Patrick 2010-12-02 16:22:05 EST
Package: firefox-4.0-0.5b7.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1.load firefox
2.close firefox
3.cant load the home page when i load firefox again
Comment 29 Raphos 2010-12-03 07:11:03 EST
Package: firefox-4.0-0.5b7.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1.Download file
2.FF crashed
3.
Comment 30 Peter Hjalmarsson 2010-12-04 04:08:25 EST
Package: firefox-4.0-0.5b7.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. Start firefox with a couple of tabs
2. download a couple of small files (torrents at ~10k)
3. About six download later firefox crashes


Comment
-----
I did only download a couple of small files. When I pressed the link to the sixth the animation on the tab started rolling as it should, but then hang. A couple of seconds of a non-responsive firefox later this crash happened.
Comment 31 Jens Petersen 2010-12-08 02:14:42 EST
Package: firefox-4.0-0.5b7.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. shutdown firefox
Comment 32 Bill Nottingham 2010-12-10 11:38:59 EST
*** Bug 662111 has been marked as a duplicate of this bug. ***
Comment 33 Matěj Cepl 2010-12-10 11:39:00 EST
*** Bug 654920 has been marked as a duplicate of this bug. ***
Comment 34 Matěj Cepl 2010-12-10 11:54:45 EST
Actually, after looking at couple of duplicates of this, it seems to me that the root of all evil may lie in

#11 0x00007f93bc0f055d in notify_notification_finalize (object=0x7f93a549f840) at notification.c:342
        obj = 0x7f93a549f840
        priv = 0x7f93a8103d60
        proxy = <value optimized out>

so that this could be some bad use (or incompatibility, I was told there were some changes in API) of libnotify.
Comment 35 Bill Nottingham 2010-12-10 11:59:33 EST
xulrunner-2.0/mozilla-central/toolkit/system/gnome/nsAlertsIconListener.cpp:

nsresult
nsAlertsIconListener::ShowAlert(GdkPixbuf* aPixbuf)
{
...
  // Fedora 10 calls NotifyNotification "closed" signal handlers with a
  // different signature, so a marshaller is used instead of a C callback to
  // get the user_data (this) in a parseable format.  |closure| is created
  // with a floating reference, which gets sunk by g_signal_connect_closure().
  GClosure* closure = g_closure_new_simple(sizeof(GClosure), this);
  g_closure_set_marshal(closure, notify_closed_marshal);
  mClosureHandler = g_signal_connect_closure(mNotification, "closed", closure, FALSE);
  gboolean result = notify_notification_show(mNotification, NULL);
...

(No evidence that this is it, but...)
Comment 36 Nicolas Mailhot 2010-12-11 13:51:51 EST
Package: firefox-4.0-0.6b7.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
While browsing
Comment 37 Nicolas Mailhot 2010-12-11 13:54:40 EST
Created attachment 468162 [details]
another backtrace
Comment 38 Yulia Kopkova 2010-12-14 16:39:18 EST
Package: firefox-4.0-0.6b7.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. not sure...
2.
3.
Comment 39 Stephen Hoekstra 2010-12-17 04:39:05 EST
Package: firefox-4.0-0.6b7.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. Ctrl+clicked on a link to open in a new window
2. Dialogue window to save link (.sh) to drive or run appeared
3. Clicked CANCEL and firefox crashed.
Comment 40 Stephen 2010-12-19 07:56:31 EST
Package: firefox-4.0-0.6b7.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. Downloaded Amazon downloader from Amazon.com
2.
3.
Comment 41 Martin Stransky 2010-12-22 11:32:17 EST
Unable to reproduce with new firefox (firefox-4.0-0.7b8.fc15), can you retest please?
Comment 42 Martin Kho 2010-12-23 14:35:05 EST
Hi Martin,

Sorry, but firefox 4.0.0.7b8.fc15.x86_64 (and xulrunner-2.0-0.12b8.fc15.x86_64) is crashing for me. I downloaded Coin2-devel-2.5.0-9.fc15.i686.rpm from [1]


Martin Kho


[1] ftp://alviss.et.tudelft.nl/pub/fedora/linux/development/x86_64/os/Packages/
Comment 43 Peter Hjalmarsson 2010-12-24 08:28:24 EST
The same versions as previous poster, and this still crash.

How I currently reproduce:
1. Open my browser with a number of saved open tabs.
2. Go to one of the tabs which when I press a button offers me to save four pretty small files to disk (it tells my browser that I want to save these files, so my browser shows four save-to-disk dialogs).
3. Save all four files (using a default location, no file-chooser dialog), and about half a second after I pressed "ok" in the last dialog: crash.
Comment 44 Bill Nottingham 2011-01-03 21:06:22 EST
Fixed.

Note You need to log in before you can comment on or make changes to this bug.