Bug 654637 - Creating subscriptions and then refreshing pools with REST API fails
Summary: Creating subscriptions and then refreshing pools with REST API fails
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Candlepin
Classification: Community
Component: candlepin
Version: 0.5
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: ---
Assignee: Ajay Kumar Nadathur Sreenivasan
QA Contact: John Sefler
URL:
Whiteboard:
Depends On:
Blocks: Entitlement-Beta
TreeView+ depends on / blocked
 
Reported: 2010-11-18 13:51 UTC by Jeff Weiss
Modified: 2015-05-14 15:22 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
0.0.43-1
Last Closed: 2010-11-18 17:50:00 UTC


Attachments (Terms of Use)
script to run api calls (665 bytes, application/x-ruby)
2010-11-18 13:51 UTC, Jeff Weiss
no flags Details

Description Jeff Weiss 2010-11-18 13:51:46 UTC
Created attachment 461297 [details]
script to run api calls

Description of problem:
I am trying to use a script to create some pools in on-premises server that are approaching expiration. The script I'm using used to work, but against 0.0.43-1, the pool refresh fails.  See exception http://pastebin.test.redhat.com/34921

Version-Release number of selected component (if applicable):
0.0.43-1

How reproducible:


Steps to Reproduce:
1. Place attached script setup.rb in dir above candlepin checkout.
2. chmod 755 setup.rb
3. ./setup.rb
4. curl -u admin:admin -k https://[host:port]/candlepin/pools?owner=[ownerid of donaldduck]

Actual results:
The pools shown are just the ones originally imported during deploy. The ones the script created do not show up.  There are exceptions in catalina.out.

Expected results:
Pools created.

Additional info:

Comment 1 Ajay Kumar Nadathur Sreenivasan 2010-11-18 17:42:41 UTC
Hi,
I am not able to reproduce the above scenario using ALPHA branch. The code works fine.


Note You need to log in before you can comment on or make changes to this bug.