Bug 654677 - [abrt] gwibber-1:2.33.0-12.894bzr.fc14: FixedVMPoolAllocator: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
Summary: [abrt] gwibber-1:2.33.0-12.894bzr.fc14: FixedVMPoolAllocator: Process /usr/bi...
Keywords:
Status: CLOSED DUPLICATE of bug 648319
Alias: None
Product: Fedora
Classification: Fedora
Component: gwibber
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:1a245d9308437da2743a769aeaa...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-18 15:21 UTC by Pete Zaitcev
Modified: 2010-11-25 03:41 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-25 03:41:00 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (52.01 KB, text/plain)
2010-11-18 15:21 UTC, Pete Zaitcev
no flags Details

Description Pete Zaitcev 2010-11-18 15:21:42 UTC
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: /usr/bin/python /usr/bin/gwibber
comment: Upgraded from F13 yesterday and it started happening.
component: gwibber
crash_function: FixedVMPoolAllocator
executable: /usr/bin/python
kernel: 2.6.35.6-48.fc14.x86_64
package: gwibber-1:2.33.0-12.894bzr.fc14
rating: 4
reason: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
How to reproduce: 1. Launch Gwibber.
time: 1290093664
uid: 531

Comment 1 Pete Zaitcev 2010-11-18 15:21:44 UTC
Created attachment 461321 [details]
File: backtrace

Comment 2 Pete Zaitcev 2010-11-18 15:24:52 UTC
Looks like a dup of bug 650567.

Comment 3 Pete Zaitcev 2010-11-18 17:20:00 UTC
Never mind, Abrt is being retarded. Here's the real traceback from gdb:

Core was generated by `/usr/bin/python /usr/bin/gwibber'.
Program terminated with signal 11, Segmentation fault.
#0  0x00007febb008c7c3 in FixedVMPoolAllocator (this=<value optimized out>)
    at JavaScriptCore/jit/ExecutableAllocatorFixedVMPool.cpp:308
308                 CRASH();
Missing separate debuginfos, use: debuginfo-install python-2.7-8.fc14.1.x86_64
(gdb) where
#0  0x00007febb008c7c3 in FixedVMPoolAllocator (this=<value optimized out>)
    at JavaScriptCore/jit/ExecutableAllocatorFixedVMPool.cpp:308
#1  JSC::ExecutableAllocator::isValid (this=<value optimized out>)
    at JavaScriptCore/jit/ExecutableAllocatorFixedVMPool.cpp:460
#2  0x00007febafff960d in ExecutableAllocator (this=0x7feba993ca00,
    globalDataType=<value optimized out>, threadStackType=
    JSC::ThreadStackTypeLarge) at JavaScriptCore/jit/ExecutableAllocator.h:170
#3  JSC::JSGlobalData::JSGlobalData (this=0x7feba993ca00,
    globalDataType=<value optimized out>, threadStackType=
    JSC::ThreadStackTypeLarge) at JavaScriptCore/runtime/JSGlobalData.cpp:151
#4  0x00007febafff9ff3 in JSC::JSGlobalData::create (type=
    JSC::ThreadStackTypeLarge) at JavaScriptCore/runtime/JSGlobalData.cpp:240
#5  0x00007febafffa042 in JSC::JSGlobalData::createLeaked (type=
    JSC::ThreadStackTypeLarge) at JavaScriptCore/runtime/JSGlobalData.cpp:246
#6  0x00007febaf249462 in WebCore::JSDOMWindowBase::commonJSGlobalData ()
    at WebCore/bindings/js/JSDOMWindowBase.cpp:160
#7  0x00007febaf29b5bc in WebCore::ScriptController::getAllWorlds (worlds=...)
    at WebCore/bindings/js/ScriptController.cpp:187
#8  0x00007febaf5e3792 in WebCore::FrameLoader::dispatchDidClearWindowObjectsInAllWorlds (this=0x7feba98fc250) at WebCore/loader/FrameLoader.cpp:3340
#9  0x00007febaf5e39e7 in WebCore::FrameLoader::receivedFirstData (this=
    0x7feba98fc250) at WebCore/loader/FrameLoader.cpp:616
#10 0x00007febaf5dc228 in WebCore::DocumentWriter::setEncoding (this=
    0x7feba98fc3a0, name=..., userChosen=false)
    at WebCore/loader/DocumentWriter.cpp:236
#11 0x00007febaf5d04c6 in WebCore::DocumentLoader::commitData (this=
    0x7feba9962800, bytes=
    0x7feba98fb900 '\n' <repeats 11 times>, "<html>\n  <head>\n    <script src=\"jquery.js\"></script>\n    <script>\n      $(document).ready(function() {\n          $(\".account\").click(function() {\n", ' ' <repeats 14 times>, "document.location = \"gwibber"..., length=2169) at WebCore/loader/DocumentLoader.cpp:300
#12 0x00007febaf9f7265 in WebKit::FrameLoaderClient::committedLoad (this=
    0x7feba98e86c0, loader=0x7feba9962800, data=
    0x7feba98fb900 '\n' <repeats 11 times>, "<html>\n  <head>\n    <script src=\"jquery.js\"></script>\n    <script>\n      $(document).ready(function() {\n          $(\".account\").click(function() {\n", ' ' <repeats 14 times>, "document.location = \"gwibber"..., length=2169)
    at WebKit/gtk/WebCoreSupport/FrameLoaderClientGtk.cpp:252
#13 0x00007febaf5d10e6 in WebCore::DocumentLoader::commitLoad (this=
    0x7feba9962800, data=
    0x7feba98fb900 '\n' <repeats 11 times>, "<html>\n  <head>\n    <script src=\"jquery.js\"></script>\n    <script>\n      $(document).ready(function() {\n          $(\".account\").click(function() {\n", ' ' <repeats 14 times>, "document.location = \"gwibber"..., length=2169) at WebCore/loader/DocumentLoader.cpp:287
#14 0x00007febaf61fa31 in WebCore::ResourceLoader::didReceiveData (this=
    0x7feba9957b00, data=
    0x7feba98fb900 '\n' <repeats 11 times>, "<html>\n  <head>\n    <script src=\"jquery.js\"></script>\n    <script>\n      $(document).ready(function() {\n          $(\".account\").click(function() {\n", ' ' <repeats 14 times>, "document.location = \"gwibber"..., length=2169, lengthReceived=2169,
    allAtOnce=<value optimized out>) at WebCore/loader/ResourceLoader.cpp:263
#15 0x00007febaf60d925 in WebCore::MainResourceLoader::didReceiveData (this=
    0x7feba9957b00, data=
    0x7feba98fb900 '\n' <repeats 11 times>, "<html>\n  <head>\n    <script src=\"jquery.js\"></script>\n    <script>\n      $(document).ready(function() {\n          $(\".account\").click(function() {\n", ' ' <repeats 14 times>, "document.location = \"gwibber"..., length=2169, lengthReceived=2169, allAtOnce=true)
    at WebCore/loader/MainResourceLoader.cpp:420
#16 0x00007febaf60ee2b in WebCore::MainResourceLoader::continueAfterContentPolicy (this=0x7feba9957b00, contentPolicy=<value optimized out>,
    r=<value optimized out>) at WebCore/loader/MainResourceLoader.cpp:276
#17 0x00007febaf60f316 in WebCore::MainResourceLoader::continueAfterContentPolicy (this=0x7feba9957b00, policy=WebCore::PolicyUse)
    at WebCore/loader/MainResourceLoader.cpp:294
#18 0x00007febaf6120d7 in WebCore::MainResourceLoader::didReceiveResponse (
    this=0x7feba9957b00, r=...) at WebCore/loader/MainResourceLoader.cpp:380
#19 0x00007febaf60fe9e in WebCore::MainResourceLoader::handleDataLoadNow (this=
    0x7feba9957b00) at WebCore/loader/MainResourceLoader.cpp:490
#20 0x00007febaf70d832 in WebCore::ThreadTimers::sharedTimerFiredInternal (
    this=0x7feba995e5a0) at WebCore/platform/ThreadTimers.cpp:112
#21 0x00007febaf9cee32 in WebCore::timeout_cb ()
    at WebCore/platform/gtk/SharedTimerGtk.cpp:49
#22 0x00007febbf5075eb in ?? () from /lib64/libglib-2.0.so.0
#23 0x00007febbf505e33 in g_main_context_dispatch ()
   from /lib64/libglib-2.0.so.0
#24 0x00007febbf506610 in ?? () from /lib64/libglib-2.0.so.0
#25 0x00007febbf506c82 in g_main_loop_run () from /lib64/libglib-2.0.so.0
#26 0x00007febbde7c0b7 in gtk_main () from /usr/lib64/libgtk-x11-2.0.so.0
#27 0x00007febbe540846 in ?? ()
   from /usr/lib64/python2.7/site-packages/gtk-2.0/gtk/_gtk.so
#28 0x00007febc99cd12b in PyEval_EvalFrameEx ()
   from /usr/lib64/libpython2.7.so.1.0
#29 0x00007febc99cf04d in PyEval_EvalCodeEx ()
   from /usr/lib64/libpython2.7.so.1.0
#30 0x00007febc99cf162 in PyEval_EvalCode ()
   from /usr/lib64/libpython2.7.so.1.0
#31 0x00007febc99ea39c in ?? () from /usr/lib64/libpython2.7.so.1.0
#32 0x00007febc99eb1d0 in PyRun_FileExFlags ()
   from /usr/lib64/libpython2.7.so.1.0
#33 0x00007febc99ebdaf in PyRun_SimpleFileExFlags ()
   from /usr/lib64/libpython2.7.so.1.0
#34 0x00007febc99fd8ce in Py_Main () from /usr/lib64/libpython2.7.so.1.0
#35 0x00007febc8cb5e7d in __libc_start_main () from /lib64/libc.so.6
#36 0x0000000000400649 in _start ()

Comment 4 Pete Zaitcev 2010-11-18 17:22:45 UTC
Why do we even need JavaScript in Gwibber? Can we tell WebKit not to
enable JS and just render static... Heck why do we even need WebKit
in the first place? I thought Twitter was about enabling non-browser
clients.

Comment 5 Tom "spot" Callaway 2010-11-18 17:24:37 UTC
Pete, the best suggestion I can give is for you to look at the gwibber source code, as it explains what is being done in python, javascript, and webkit.

Comment 6 Pete Zaitcev 2010-11-21 02:56:03 UTC
Looks like a dup of bug 648319.

Comment 7 Kevin Fenzi 2010-11-21 04:20:20 UTC
Is this in a vmware guest?

rpm -q webkitgtk ?

Comment 8 Pete Zaitcev 2010-11-25 03:41:00 UTC

*** This bug has been marked as a duplicate of bug 648319 ***


Note You need to log in before you can comment on or make changes to this bug.