Bug 654701 - Console session not marked as active
Console session not marked as active
Status: CLOSED DUPLICATE of bug 643367
Product: Fedora
Classification: Fedora
Component: ConsoleKit (Show other bugs)
14
Unspecified Unspecified
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-11-18 11:28 EST by Tim Waugh
Modified: 2010-11-20 07:43 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-11-20 07:43:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2010-11-18 11:28:08 EST
Description of problem:
The console session is not marked as active.  The particular symptom I'm seeing as a result is that USB device nodes for HP printers do not have ACLs set for the console user.

Version-Release number of selected component (if applicable):
ConsoleKit-0.4.2-2.fc14.1.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Log in at console.
2.ck-list-sessions
  
Actual results:
Session2:
	unix-user = '500'
	realname = 'Tim Waugh'
	seat = 'Seat1'
	session-type = ''
	active = FALSE
	x11-display = ':0'
	x11-display-device = '/dev/tty1'
	display-device = ''
	remote-host-name = ''
	is-local = TRUE
	on-since = '2010-11-18T08:47:49.504969Z'
	login-session-id = '1'

Expected results:
Session2:
	unix-user = '500'
	realname = 'Tim Waugh'
	seat = 'Seat1'
	session-type = ''
	active = TRUE
	x11-display = ':0'
	x11-display-device = '/dev/tty1'
	display-device = ''
	remote-host-name = ''
	is-local = TRUE
	on-since = '2010-11-18T08:47:49.504969Z'
	login-session-id = '1'

Additional info:
This causes udev-acl to perform no action instead of adding ACLs.
Comment 1 Tim Waugh 2010-11-20 07:43:57 EST

*** This bug has been marked as a duplicate of bug 643367 ***

Note You need to log in before you can comment on or make changes to this bug.