This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 65472 - Internet Connection Wizard does not support 10-digit dialing
Internet Connection Wizard does not support 10-digit dialing
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: wvdial (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-24 19:19 EDT by Need Real Name
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-16 09:06:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-05-24 19:19:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020408

Description of problem:
I live in the Portland, Oregon area.  We have two area codes with no
geographical boundaries, hence we must dial an area code with all outgoing calls.

There is no check box in the ICW that will cause the dialer script to dial the
area code in addition to the 7 digit number, and I think there should be.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Add a new network connection using the Internet Configuration Wizard
2. Note on the phone number step there is a separate box for area code.
3. Enter an area code and phone number into the appropriate places.
4. Save the record.
5. Start the dialer and note that it does not dial the area code, and there was
never any option forcing it to do so.

Additional info:

Workaround: include the area code in the phone number field.  Sort of ugly, but
works fine.
Comment 1 Ngo Than 2002-06-05 10:16:37 EDT
it's a bug in wvdial. assigned it to right component
Comment 2 Need Real Name 2002-06-05 14:36:01 EDT
Is wvdial responsible for presenting the GUI to the user and writing the
configuration files?  Because the problem could be solved at that level by
writing the appropriate information into the number to be dialed field of the
config file.  

Perhaps there should also be a feature request for wvdial, because an ideal
solution would require changes to both the ICW and wvdial -- to support a new
boolean parameter indicating 10-digit dialing -- but I really don't think this
is just a wvdial bug.

Comment 3 Harald Hoyer 2005-09-16 09:06:54 EDT
WONTFIX, cause the GUI does not exist anymore

Note You need to log in before you can comment on or make changes to this bug.