Bug 654734 - .NET Binding class Address mishandles Name and Type fields
Summary: .NET Binding class Address mishandles Name and Type fields
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-sdk
Version: 1.3
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: 3.0
: ---
Assignee: Chuck Rolke
QA Contact: Petra Svobodová
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-18 18:02 UTC by Chuck Rolke
Modified: 2014-09-24 15:02 UTC (History)
3 users (show)

Fixed In Version: 0.7.946106-24
Doc Type: Bug Fix
Doc Text:
Previously, the Address.Type value could overwrite the Address.Name value and left the Address.Type value unchanged when users cut and pasted in the source. Due to this issue, address objects did not receive the correct Name and Type fields. This update resolves this error and verifies that the Name and the Type fields are set correctly. Now, the Address, Name, and Type fields work correctly.
Clone Of:
Environment:
Last Closed: 2014-09-24 15:02:03 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Apache JIRA QPID-2952 0 None None None Never
Red Hat Product Errata RHEA-2014:1296 0 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging 3.0 Release 2014-09-24 19:00:06 UTC

Description Chuck Rolke 2010-11-18 18:02:33 UTC
Description of problem:

Creating or setting an address's Type field overwrites the Name field.

Version-Release number of selected component (if applicable):

1.3.0.18

How reproducible:

100%

Steps to Reproduce:
1. Create an address with a type.
2.
3.
  
Actual results:

The address's name becomes what the type specified.

Expected results:

The address's type field should get the type specified and the name should be unchanged.

Additional info:

Comment 1 Chuck Rolke 2010-11-18 18:03:49 UTC
Fixed upstream 11/18/2010
QPID-2952
r1036558

Comment 2 Chuck Rolke 2010-11-18 21:58:18 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Cause: Cut-paste type in source caused Address.Type values to overwrite Address.Name values and to leave the Address.Type value unchanged.

Consequence: Address objects do not receive proper Name and Type fields.

Fix: Repair the error and verify that Name and Type fields are set correctly.

Result: Address Name and Type fields work properly.

Comment 3 Florian Nadge 2011-02-10 11:38:14 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1,7 +1 @@
-Cause: Cut-paste type in source caused Address.Type values to overwrite Address.Name values and to leave the Address.Type value unchanged.
+Previously, the Address.Type value could overwrite the Address.Name value and left the Address.Type value unchanged when users cut and pasted in the source. Due to this issue, address objects did not receive the correct Name and Type fields. This update resolves this error and verifies that the Name and the Type fields are set correctly. Now, the Address, Name, and Type fields work correctly.-
-Consequence: Address objects do not receive proper Name and Type fields.
-
-Fix: Repair the error and verify that Name and Type fields are set correctly.
-
-Result: Address Name and Type fields work properly.

Comment 4 Petra Svobodová 2013-05-07 07:02:10 UTC
The bug was reproduced on qpid-cpp-winsdk-1.3.0.18; on qpid-cpp-win-3.2.0.4-1 did not occur.

Comment 8 Petra Svobodová 2013-11-01 13:47:22 UTC
The issue does not occur on the current packages. 

Verified on qpid-cpp-win-3.22.23.1-1 on Windows platforms:
- WindowsXP-x86
- Windows7-x86 and x64
- Windows Server2003-x86 and x64
- Windows Server2008-x86, x64 and R2

--> VERIFIED

Comment 10 errata-xmlrpc 2014-09-24 15:02:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-1296.html


Note You need to log in before you can comment on or make changes to this bug.