Bug 65474 - Redhat 7.3 will not install, see Service Request 206183.
Redhat 7.3 will not install, see Service Request 206183.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.3
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-24 23:21 EDT by Fred Krogh
Modified: 2007-04-18 12:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-03 01:15:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from sysreport (91.17 KB, application/octet-stream)
2002-06-04 12:01 EDT, Fred Krogh
no flags Details

  None (edit)
Description Fred Krogh 2002-05-24 23:21:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0rc2) Gecko/20020510

Description of problem:
There is nothing to expand upon past the summary.  There is a
sysreport output in an attachment for Service Request 206183.

Note that I simply can not install this software as an upgrade.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Go through the install process.
2. English, US 105 keyboard, Microsoft Intellimouse.
3. Doing a custom install with custom packages.
4. Then it insists the file system was not umounted cleanly.
	

Actual Results:  See above.

Expected Results:  It would proceed with an installation.

Additional info:

Nothing additional to add.
Comment 1 Michael Fulbright 2002-06-04 11:41:31 EDT
Unfortunately this bug tracker is not tied into the support tracker for privacy
reasons.  Could you describe the problem you are having and we'll try to help.
Comment 2 Fred Krogh 2002-06-04 12:01:51 EDT
Created attachment 59526 [details]
Output from sysreport
Comment 3 Fred Krogh 2002-06-04 12:03:01 EDT
My initial statement of the problem was:

I am trying to upgrade a Redhat 7.1 system.  I'm getting the message
"One or more of the file systems for your Linux
system was not unmounted cleanly. Please boot ..."

When booting there are no complaints.  I do the usual shutdown, try again
the same result.  I am attempting to do a custom upgrade.

HELP!

Thanks,
	 Fred

I can also be reache by phone at (818)352-3244, call collect if that helps.

==============

It was suggested that I boot with linux rescue off the CD and run fsck.  This in
fact did complain about some of the partitions.  These problems were cleared up,
but the initial problem remained.  From my next to last response on this:

==============

To close this out, I've tried the following.
1. Replaced my DVD drive with a CD drive.
2. Removed hdb and removed references to it in fstab.
3. Removed some of the partitions on hda from fstab.
4. Run fsck on all remaining paritions, including the floppy drive.

The attempt to install results in the same error as has been discussed
previously.  For god's sake, change your diagnostic to indicate which
partition it is complaining about!  I'd be happy to check out the
changed code.

===========

This above was not my first complaint about the quality of the diagnostics.  I
have been writing mathematical software since 1958.  It took me a while, but I
finally learned that when my code detects some kind of problem it pays big
dividends to dump out everything that could possibly be connected with the error
as part of an error message.  I recommend this policy to you.

============

At one point it was requested that I send the output from sysreport.  Thus I
have attached this information here.  This run claimed failure on collecting
information about X, rtc, sound devices, /proc/bus (twice), and
/etc/sendmail.cf.   The latter may be due to the fact that I am running postfix.

Many thanks for the help,
            Fred
Comment 4 Fred Krogh 2002-06-04 23:22:14 EDT
I've just sent the following to "support".

If only I had read the Installation Guide carefully, or even better if
your diagnostics had pointed me in the right direction, I'd have known about
cntrl-alt-F3.  This told me the complaint was about /dev/hda7.  So I tried
changing the line

LABEL=x1
	/x1			ext2	defaults	0 0

to start with "/dev/hda7" instead of "Label=x1" and amazingly it got past this
diagnostic.  It then hung on /dev/hdb6.  Making a similar change there didn't
get around the problem.  So I just commented out all references to hdb.

The installation then went through quite smoothly.  I then uncommented the
references to /dev/hdb in fstab, and all seems to be working.  For what it
is worth, hda and hdb are on the same ide channel with hda the master and hdb
the slave.  Note that I did run e2fsck on the hdb entries prior to commenting
them out and they all checked out o.k.  It still looks like there is a problem
in the installer, but not one I couldn't work around.

Thanks for the help,
          Fred
Comment 5 Jeremy Katz 2002-06-21 17:34:46 EDT
If you look in /tmp/syslog using tty2 in the installer, do you see hdb get
detected by the kernel?  Additionally, if you do tune2fs -l on the devices which
didn't get recognized, are the labels on them properly shown?
Comment 6 Fred Krogh 2002-06-21 17:44:16 EDT
Sorry /tmp/syslog is no longer there, and I'm afraid I'm not willing to do a new
install to check this out.  "tune2fs -l /dev/hdb6" gives

Filesystem volume name:   y0

which was what was used for the label.  Note that when doing the install I
changed from using the "LABEL=" syntac to using "/dev/hdb6" in fstab, and it
still complained about hdb6.  I'm guessing the kernel say hdb6, since if it
didn't see it, I don't see how it could have complained about it not being
unmouned cleanly.
Comment 7 Bryce Nesbitt 2002-07-01 16:43:21 EDT
I get the same very unhelpful message "One or more of the filesystems was not 
unmounted cleanly".  I can't upgrade to 7.3.
Comment 8 Bryce Nesbitt 2002-07-01 16:47:25 EDT
The installer, it seems, parses /etc/fstab differently from Linux.
It does not seem to respect comments and the noauto flag quite the same way.  
So your Linux system can boot fine, but you can't install.  But so far I've not 
discovered secret to help me.

The microsoft-quality error message does not help.
Comment 9 Jeremy Katz 2003-01-03 01:15:38 EST
This should be handled better in our current codebase with better diagnostic
errors to allow you to fix any actual problems.

Note You need to log in before you can comment on or make changes to this bug.