Bug 65483 - USB module hangs on Compaq Presario 1210US notebook
Summary: USB module hangs on Compaq Presario 1210US notebook
Status: CLOSED DUPLICATE of bug 91889
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 9
Hardware: athlon
OS: Linux
medium
high
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-05-25 11:36 UTC by A. Alper ATICI
Modified: 2007-04-18 16:42 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-11 13:01:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description A. Alper ATICI 2002-05-25 11:36:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
I boot from Valhalla CD#1, enter "linux nousb" at the prompt, 
and this is what I get last on screen:

usb.c :      registered new driver usbdevfs
usb.c :      registered new driver hub
usb-uhci.c : $Revision: 1.275 $ time 06:55:51 Apr 18 2002 
usb-uhci.c : High bandwidth mode enabled
usb-uhci.c : USB UHCI at I/O 0x1800, IRQ 5
usb-uhci.c : Detected 2 ports
usb.c :      new USB bus registered, assigned bus number 1


and then freeze...	

Additional info:

Adding noprobe and/or nousbstorage makes no difference at all.

I used to install Seawolf successfully on this notebook by entering 
"linux nousb" at the boot prompt.

Comment 1 Joshua SS Miller 2002-05-28 02:32:17 UTC
same on Compaq Presario 1215US, used to use nousb or noauto for kernel params.

Comment 2 Michael Fulbright 2002-06-04 15:39:58 UTC
Jeremy is there additonal options you have to give to stop USB modules from loading?

Comment 3 Jeremy Katz 2002-06-04 15:56:32 UTC
USB is built into the BOOT kernel.  Arjan, is there a way to get it not probed
like this?

Comment 4 Arjan van de Ven 2002-06-04 18:17:07 UTC
There is no kernel side option;
however the "apic" option might actually fix the USB hang itself :(

Comment 5 Joshua SS Miller 2002-06-07 01:30:42 UTC
linux apic

did not work on the compaq 1215US

Comment 6 Joshua SS Miller 2002-06-25 23:22:11 UTC
Is anyone still working on this issue?  Maybe a optional boot image would be nice?

Comment 7 A. Alper ATICI 2003-05-22 13:53:52 UTC
Hey, long time... but the core problem (i.e. modprobe hangs in rc.sysinit) 
remains.

I've figured out a solution: Enabling ACPI in kernel resolves this issue (make 
sure it's not overridden by apm).


Comment 8 Alan Cox 2003-06-05 17:54:23 UTC
A "nousb" option did arrive later on (eg in RH9)


Comment 9 Alan Cox 2003-06-09 14:06:25 UTC

*** This bug has been marked as a duplicate of 91889 ***

Comment 10 A. Alper ATICI 2003-06-11 13:01:34 UTC
I have to correct: this notebook does not have Radeon IGP. It has Rage Mobility 
M1, Via VT82C686A south (almost 2 years old).
I have to clarify: I do know about "nousb" option, but don't fancy for it as 
I'd get a system without usb support.



Note You need to log in before you can comment on or make changes to this bug.