Bug 654830 - [abrt] nted-1.10.13-1.fc14: NedVoice::pasteElements: Process /usr/bin/nted was killed by signal 11 (SIGSEGV)
Summary: [abrt] nted-1.10.13-1.fc14: NedVoice::pasteElements: Process /usr/bin/nted wa...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nted
Version: 14
Hardware: x86_64
OS: Unspecified
low
medium
Target Milestone: ---
Assignee: Hans Ulrich Niedermann
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:24cc7b902b91476bdb8a8a295fc...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-18 20:29 UTC by John Williams
Modified: 2011-02-03 20:23 UTC (History)
1 user (show)

Fixed In Version: nted-1.10.17-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-03 20:23:49 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (45.28 KB, text/plain)
2010-11-18 20:29 UTC, John Williams
no flags Details

Description John Williams 2010-11-18 20:29:02 UTC
abrt version: 1.1.13
architecture: x86_64
Attached file: backtrace
cmdline: nted
component: nted
crash_function: NedVoice::pasteElements
executable: /usr/bin/nted
kernel: 2.6.35.6-48.fc14.x86_64
package: nted-1.10.13-1.fc14
rating: 4
reason: Process /usr/bin/nted was killed by signal 11 (SIGSEGV)
release: Fedora release 14 (Laughlin)
time: 1290111863
uid: 500

How to reproduce
-----
1.Select a block of music
2.Edit > Copy
3.Click to highlight a rest in an empty bar. Edit > Paste.

Comment 1 John Williams 2010-11-18 20:29:06 UTC
Created attachment 461381 [details]
File: backtrace

Comment 2 Hans Ulrich Niedermann 2011-01-25 17:43:35 UTC
I cannot reproduce this on my (i686) system. Could you try and see whether the nted-1.10.17-1 happens to fix the issue?

https://admin.fedoraproject.org/updates/nted-1.10.17-1.fc14

Comment 3 John Williams 2011-01-25 20:02:17 UTC
Hi, 
I downloded nted-1.10.17-1.fc14.x86_64 from the link but when I tried to install it I got dependency errors:-
"nted-1.10.17-1.fc14.x86_64 requires nted-doc = 1.10.17-1.fc14
nted-1.10.17-1.fc14.x86_64 requires nted-ntedfont-fonts = 1.10.17-1.fc14"

Comment 4 Hans Ulrich Niedermann 2011-01-26 22:22:41 UTC
I don't know whether we have an easy way to install packages with dependencies using the GUI tools. However, that build has now arrived on the mirrors in updates-testing, so running

    yum --enablerepo=updates-testing update nted

as root is the only direct way I can give you to install and test that new build.

If you want to go back to the normal nted release in the usual updates, you can remove the currently installed nted again and install the default nted again with the following two commands:

    yum remove nted nted-doc nted-ntedfont-fonts
    yum install nted

Comment 5 John Williams 2011-01-26 22:43:35 UTC
Hi,

I did as root:
yum --enablerepo=updates-testing update nted

After updating I did several copy and paste operations but I could not reproduce the crash. It's working well.

Regards,
John.

Comment 6 Hans Ulrich Niedermann 2011-01-27 15:24:16 UTC
Great, thanks for testing!

Comment 7 Fedora Update System 2011-01-27 20:00:57 UTC
nted-1.10.17-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/nted-1.10.17-1.fc14

Comment 8 Fedora Update System 2011-01-27 20:02:02 UTC
nted-1.10.17-1.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/nted-1.10.17-1.fc13

Comment 9 Fedora Update System 2011-02-03 20:23:37 UTC
nted-1.10.17-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.