Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 654887 - mke2fs Warning, had trouble writing out superblocks.
Summary: mke2fs Warning, had trouble writing out superblocks.
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 14
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-18 22:56 UTC by Barry Godusky
Modified: 2013-01-10 06:20 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-19 23:15:47 UTC
Type: ---


Attachments (Terms of Use)
bug report from crash (366.67 KB, text/plain)
2010-11-18 22:56 UTC, Barry Godusky
no flags Details

Description Barry Godusky 2010-11-18 22:56:36 UTC
Created attachment 461412 [details]
bug report from crash

Description of problem: Installing FD14 when anaconda crashed with a bug check.


Version-Release number of selected component (if applicable):


How reproducible: Install from cdrom onto a 250GB drive through the live desktop spin of FXCE


Steps to Reproduce:
1.Run install from cdrom and use firefox while formatting LVG. Also it stated it could not mount drive data due to the drive enclosure being locked.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Brian Lane 2010-11-19 01:46:32 UTC
anaconda 14.22 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/formats/fs.py", line 372, in doFormat
    raise FormatCreateError("format failed: %s" % ret.rc, self.device)
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/formats/fs.py", line 937, in doFormat
    FS.doFormat(self, *args, **kwargs)
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/formats/fs.py", line 851, in create
    return self.doFormat(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/deviceaction.py", line 290, in execute
    options=self.device.formatArgs)
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 700, in processActions
    action.execute(intf=self.intf)
  File "/usr/lib/python2.7/site-packages/pyanaconda/storage/__init__.py", line 313, in doIt
    self.devicetree.processActions()
  File "/usr/lib/python2.7/site-packages/pyanaconda/packages.py", line 110, in turnOnFilesystems
    anaconda.storage.doIt()
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 212, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/python2.7/site-packages/pyanaconda/dispatch.py", line 131, in gotoNext
    self.moveStep()
  File "/usr/lib/python2.7/site-packages/pyanaconda/gui.py", line 1190, in nextClicked
    self.anaconda.dispatch.gotoNext()
FormatCreateError: ('format failed: 1', '/dev/mapper/vg_sabrenet-lv_root')



Something went bad while writing the superblocks:

21:42:12,497 INFO program: Running... mke2fs -t ext4 /dev/mapper/vg_sabrenet-lv_root
21:43:45,339 INFO program: Filesystem label=
21:43:45,342 INFO program: OS type: Linux
21:43:45,342 INFO program: Block size=4096 (log=2)
21:43:45,343 INFO program: Fragment size=4096 (log=2)
21:43:45,343 INFO program: Stride=0 blocks, Stripe width=0 blocks
21:43:45,344 INFO program: 2252800 inodes, 9003008 blocks
21:43:45,344 INFO program: 450150 blocks (5.00%) reserved for the super user
21:43:45,344 INFO program: First data block=0
21:43:45,345 INFO program: Maximum filesystem blocks=0
21:43:45,347 INFO program: 275 block groups
21:43:45,348 INFO program: 32768 blocks per group, 32768 fragments per group
21:43:45,349 INFO program: 8192 inodes per group
21:43:45,349 INFO program: Superblock backups stored on blocks: 
21:43:45,356 INFO program: 	32768, 98304, 163840, 229376, 294912, 819200, 884736, 1605632, 2654208, 
21:43:45,357 INFO program: 	4096000, 7962624
21:43:45,358 INFO program: 
21:43:45,358 INFO program: Writing inode tables:   [snipped]
21:43:45,359 ERR program: mke2fs 1.41.12 (17-May-2010)
21:43:45,360 ERR program: 
21:43:45,360 ERR program: Warning, had trouble writing out superblocks.
21:43:46,761 INFO program: Running... dmsetup info --columns --noheadings -o devno vg_bgodusky-lv_swap
21:43:46,773 ERR program: Device does not exist.
21:43:46,774 ERR program: Command failed

Comment 2 Chris Lumens 2010-12-07 21:16:53 UTC
Eric - What kinds of conditions usually cause that error message?  It's certainly a new one for me.

Comment 3 Eric Sandeen 2010-12-07 21:34:24 UTC
Alt-F<whatever>, and looking at the kernel log might shed some light.  IO error of some sort I'd guess ... wish we printed the error instead of just "failed" :/

Comment 4 Chris Lumens 2010-12-07 22:10:20 UTC
The kernel messages should be in the traceback in the original comment (search for dmesg - must be a live install and perhaps there is the key).  But it was not particularly enlightening for me.

Comment 5 Barry Godusky 2010-12-07 22:12:39 UTC
Chris, Eric

If there is something I can do to help with this I'd be more then happy to do so.

If you have a script and a command line set-up to run to give further information during the install I'll be happy to run it during the install process from a command line. I was kinda surprised myself at the crash. It's as if the drive just disappeared from the system from what I understand of the crash report.

Comment 6 Eric Sandeen 2010-12-07 22:33:17 UTC
So, it looks like the 250G disk is an external disk?

[    2.933283] scsi 0:0:0:0: Direct-Access     Initio   WD2500BEVE-00A0H 1.06 PQ: 0 ANSI: 0

which is USB apparently:

21:03:16,459 DEBUG storage:             DeviceTree.addUdevDevice: info: {'ID_VENDOR_ID': '13fd', 'ID_PART_TABLE_TYPE': 'dos', 'ID_USB_INTERFACE_NUM': '00', 'ID_REVISION': '1.06', 'ID_VENDOR_ENC': 'Initio\\x20\\x20', 'ID_PATH': 'pci-0000:00:13.2-usb-0:1:1.0-scsi-0:0:0:0', 'ANACBIN': '/sbin', 'UDISKS_PARTITION_TABLE_COUNT': '1', 'ID_VENDOR': 'Initio',


I also see:

[  266.080028] usb 1-1: reset high speed USB device using ehci_hcd and address 2

at the end.

I am guessing that the external storage is being flaky but I'm not certain if that last message is indicative of a problem.

Chris, does anaconda capture the errno from a failed command?  If so mke2fs should tell us if it was an EIO or what...

Comment 7 Eric Sandeen 2010-12-07 22:45:07 UTC
21:43:45,360 ERR program: Warning, had trouble writing out superblocks.
21:43:46,761 INFO program: Running... dmsetup info --columns --noheadings -o devno vg_bgodusky-lv_swap
21:43:46,773 ERR program: Device does not exist.
21:43:46,774 ERR program: Command failed

"ENODEV" would seem to square with that theory as well.

Comment 8 Jesse Keating 2012-07-19 23:15:47 UTC
Can't really help flaky hardware causing the disk to go away :/


Note You need to log in before you can comment on or make changes to this bug.