Bug 654924 - blkid detects ext3 filesystem on partitioned device
Summary: blkid detects ext3 filesystem on partitioned device
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: util-linux-ng
Version: 14
Hardware: i686
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-19 02:55 UTC by sgodsell@hotmail.com
Modified: 2012-02-21 18:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-21 18:34:41 UTC
Type: ---


Attachments (Terms of Use)
This is the output file from storage.log while running liveinst -d (103.57 KB, text/plain)
2010-11-19 02:55 UTC, sgodsell@hotmail.com
no flags Details

Description sgodsell@hotmail.com 2010-11-19 02:55:45 UTC
Created attachment 461437 [details]
This is the output file from storage.log while running liveinst -d

Description of problem:
 Anaconda does not list any partitions on a sd card.  Also you cannot select
 the partitions from an sd card (mmcblk0p?)

Version-Release number of selected component (if applicable):
 

How reproducible:
 Everytime

Steps to Reproduce:
1. Boot off Fedora 14 live usb
2. Run liveinst (make sure you have an sd card in the computer :-) )
3.
  
Actual results:


Expected results:
 Be able to install Fedora 14 on a sd card

Additional info:

Comment 1 David Lehman 2010-11-19 15:58:11 UTC
blkid says that mmcblk0 contains an ext3 filesystem. Since mmcblk0p1 also exists there must be evidence of both a partition table and an ext3 filesystem on the device. Reassigning to blkid...

Comment 2 Karel Zak 2010-11-25 09:51:08 UTC
blkid does not check for collision between partition table and filesystem. The device should be properly partitioned/formatted to avoid ambivalent probing results.

Please, use the wipefs(8) command to remove the filesystem from the device or use parted(8) to remove the partition table from the device.

(I'm not sure what is expected on the device -- you can also zeroize whole device by dd(1) or cat /dev/zero > <device>. Be careful to not lost any data.)

That's strange that anaconda does not allow to clean up the device.

Comment 3 Karel Zak 2012-02-21 18:34:41 UTC
Please, reopen if you're able to reproduce this problem on Fedora 16 or Fedora 17. Thanks.


Note You need to log in before you can comment on or make changes to this bug.