This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 65493 - Installer crash "IOError: [Errno 21] Is a directory" on upgrade 7.2 -> 7.3
Installer crash "IOError: [Errno 21] Is a directory" on upgrade 7.2 -> 7.3
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-05-25 13:19 EDT by adrian.lawrence
Modified: 2007-04-18 12:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-06-05 13:21:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anacoda/python dump file (75.70 KB, text/plain)
2002-05-25 13:36 EDT, adrian.lawrence
no flags Details

  None (edit)
Description adrian.lawrence 2002-05-25 13:19:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2.1) Gecko/20010901

Description of problem:
Anaconda reports unhandled exception: error log written to floppy.

 File "/usr/lib/anaconda/dispatch.py", line 144, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/dispatch.py", line 209, in moveStep
    rc = apply(func, self.bindArgs(args))
  File "/usr/lib/anaconda/upgrade.py", line 417, in upgradeFindPackages
    for line in f.readlines():
IOError: [Errno 21] Is a directory

I would attach the complete log file if the buzilla form offered that option :-(

How reproducible: Always

Steps to Reproduce:
1. Boot from 7.3 installation 1 CD.
2. Choose upgrade and then customize.
3. Wait for unhandled exception report
	

Actual Results:  Exception reported

Additional info:

Appears to be trying to read /etc/sysconfig/i18n

After re boot into 7.2, 
$ ls -ld /etc/sysconfig/i18n/
drwxrwxr-x    2 root     root         4096 Aug 14  2001 /etc/sysconfig/i18n/
$ ls -l /etc/sysconfig/i18n/
total 0
Comment 1 adrian.lawrence 2002-05-25 13:36:42 EDT
Created attachment 58525 [details]
anacoda/python dump file
Comment 2 adrian.lawrence 2002-05-25 13:52:38 EDT
Deleting /etc/sysconfig/i18n and trying again is a work around.
Comment 3 Michael Fulbright 2002-06-04 11:37:11 EDT
Do you know why the i18n entry was a directory?  We have not shipped it this way
in the past.
Comment 4 adrian.lawrence 2002-06-05 13:21:19 EDT
No, I don't know what created /etc/sysconfig/i18n

But I remember hitting this same problem on at least one other machine when
upgrading in the past, perhaps from 7.2 --> 7.2. Since I deleted the directory
then, I am pretty sure that some rpm is creating it. I sometimes install RPMs
not from Redhat sites, and maybe one of them is responsible. But one of my first
actions after the problem was "rpm -qf /etc/sysconfig/i18n" and I got no hits.

Is it a big problem to add the check to anaconda? 

Comment 5 Michael Fulbright 2002-06-06 12:57:27 EDT
Well to wrap every place we create/open/read/write a file would be alot of work.
TO be honest this is the first time I've seen this issue.

If I start to see more we'll reconsider addressing this issue.

Note You need to log in before you can comment on or make changes to this bug.