Bug 654958 - Open Office can not run nfs mounted home
Summary: Open Office can not run nfs mounted home
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 14
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-19 07:11 UTC by kazimsarikaya
Modified: 2010-11-26 10:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-26 10:30:44 UTC


Attachments (Terms of Use)

Description kazimsarikaya 2010-11-19 07:11:33 UTC
Description of problem:
My home is nfs (v3) mounted. If i try to open some of openoffice programs like calc or impress the program gives the error: "The operation is not supported on this operating system." 

If i open writer it can run.

If i open the root user (not mounted from nfs) all programs can run with no problem. 

Version-Release number of selected component (if applicable):
3.3.0-14.1.fc14.i686


How reproducible:
Try to open calc, impress when home dir is nfs mounted.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Caolan McNamara 2010-11-20 13:58:19 UTC
Writer can launch, but not calc/impress. That's quite odd. Can you get the output of

strace -f /usr/lib/openoffice.org3/program/scalc.bin -calc > /tmp/output.txt 2>&1

for the case where the "unsupported" dialog appears.

Comment 2 Caolan McNamara 2010-11-25 15:50:25 UTC
Is this still a problem. If so are you able to provide the requested info ?

Comment 3 kazimsarikaya 2010-11-25 16:18:39 UTC
I mannually create the required files of openoffice manually with creating a new user without nfs mounted home dir and copied the files. However i have some other lock problems. I thinks it is not about openoffice. I search the main problem. Like sometimes google chrome or thunderbird hangs and can not open, computer can not restart etc. I use a laptop. however it always open. It is pluged to ups. no battary. However i think the harddisk suspends. Hence the nfs locks died. I re configured system not to suspend harddisk. Today my first try there is no problem with any program. I need to test it for a week. Then i can said the problem is from spin downing of harddisks. Sorry for the bug report thread without i am not sure the problem source.

Have a good day.

Comment 4 Caolan McNamara 2010-11-26 10:30:44 UTC
Lets assume for the moment that its not a specific OpenOffice.org problem seeing as it seems to affect quite a few things.


Note You need to log in before you can comment on or make changes to this bug.