Bug 654990 - Certificate prompt window does not autosize
Summary: Certificate prompt window does not autosize
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: 389
Classification: Retired
Component: UI - General UI
Version: 1.2.6
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Nathan Kinder
QA Contact: Viktor Ashirov
URL:
Whiteboard:
Depends On:
Blocks: 434915
TreeView+ depends on / blocked
 
Reported: 2010-11-19 09:32 UTC by Gerhardus Geldenhuis
Modified: 2015-12-07 17:05 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-12-07 17:05:19 UTC


Attachments (Terms of Use)
Patch (947 bytes, patch)
2011-02-21 20:01 UTC, Nathan Kinder
nhosoi: review+
Details | Diff

Description Gerhardus Geldenhuis 2010-11-19 09:32:38 UTC
Description of problem:
When you access the console for the first time using https: it will prompt you to accept the certificates. If you have a smallish window say 1024x768 the certificate prompting form will stretch over the whole screen and you can see any buttons to press. With a very basic window manager you are then stuck because you can't move the window to click yes/accept on the form

Version-Release number of selected component (if applicable):
1.2.7rc7

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
Would like to see a form that takes the current screen's dimensions into account.

Additional info:

Comment 1 Rich Megginson 2010-11-19 14:27:45 UTC
I think you can work around this by installing the CA cert in ~/.389-console:

certutil -d ~/.389-console -A -t CT,, -n "my ca cert" -a -i /path/to/cacert.asc

Comment 2 Gerhardus Geldenhuis 2010-11-19 20:36:10 UTC
Thanks, I have been doing that until now. I also tried to change the saved values in .389-console directory for the x and y location of the window but that just got ignored. I had a slightly different problem with a remote vncserver session where the 389console appeared out of the window region or just on the edge making it difficult to bring it into the center.

I mention it here because it is also a windowing problem.

Regards

Comment 4 Nathan Kinder 2011-02-21 20:01:13 UTC
Created attachment 479987 [details]
Patch

The JTextArea that we use in the dialog that prompts for certificate trust is unable to determine it's proper preferred size since it is created with no rows and no columns.  This requires us to call pack() twice before it can get it's proper preferred size.  This is detailed in http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=4446522.

Comment 5 Nathan Kinder 2011-02-21 20:58:38 UTC
Checked into console (HEAD).  Thanks to Noriko for her review!

Checking in src/com/netscape/management/client/security/PromptForTrustDialog.java;
/cvs/dirsec/console/src/com/netscape/management/client/security/PromptForTrustDialog.java,v  <--  PromptForTrustDialog.java
new revision: 1.2; previous revision: 1.1
done

Comment 6 Amita Sharma 2011-07-07 10:52:48 UTC
Checked in latest release, did not face this issue.
Hence marking as VERIFIED.


Note You need to log in before you can comment on or make changes to this bug.