Bug 655013 - RFE: mac/vlan programming in macvtap with SR-IOV
Summary: RFE: mac/vlan programming in macvtap with SR-IOV
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.1
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: rc
: ---
Assignee: Michael S. Tsirkin
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 668712 678488 (view as bug list)
Depends On:
Blocks: GSS_6_2_PROPOSED 758829 580954 635428 756082
TreeView+ depends on / blocked
 
Reported: 2010-11-19 11:12 UTC by Michael S. Tsirkin
Modified: 2018-11-14 16:20 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-03 16:05:52 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Michael S. Tsirkin 2010-11-19 11:12:22 UTC
The following kernel functionality is missing
to make macvtap with SRIOV support same functionality
as one supported by tap with bridge.
This is used by qemu-kvm and so is required to make
kvm support macvtap with SRIOV at the same level
as tap with bridge, which was requested from kvm in 6.1.

At the moment the macvtap interface connects to a device
and adds a single new mac to it. The mac can not be changed
and new addresses can not be added through the macvtap fd.
For multicast, the multicast addresses can not be programmed
through the macvtap fd. At least with intel cards, SRIOV functions
themselves only support one mac address so macvtap can not bind to these.
Similar issue for vlans. 

Contrast this with tap which when connected to a bridge
can accept packets for any number of addresses.

Comment 2 Ding-Yi Chen 2010-11-21 23:31:12 UTC
(In reply to comment #0)
> The following kernel functionality is missing
> to make macvtap with SRIOV support same functionality
> .......................

Not sure this is relevant to man-pages-es (Spanish man pages).

Comment 4 RHEL Program Management 2011-01-07 04:22:18 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 5 Suzanne Yeghiayan 2011-01-07 16:23:43 UTC
This request was erroneously denied for the current release of Red Hat
Enterprise Linux.  The error has been fixed and this request has been
re-proposed for the current release.

Comment 6 RHEL Program Management 2011-02-01 05:53:12 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 7 RHEL Program Management 2011-02-01 18:52:39 UTC
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.

Comment 8 Alex Williamson 2011-02-28 21:08:51 UTC
*** Bug 678488 has been marked as a duplicate of this bug. ***

Comment 10 Suzanne Yeghiayan 2011-03-28 20:28:37 UTC
Since RHEL 6.1 External Beta has begun, and this bug remains 
unresolved, it has been rejected as it is not proposed as an 
exception or blocker.  It has been moved to RHEL 6.2 since 
it is a FutureFeature request.

Comment 11 roprabhu 2011-06-27 20:59:13 UTC
Hi Michael, is any one working on this ?. 

I saw this 
http://www.linux-kvm.org/page/GuestProgrammableMacVlanFiltering

and i also contacted Dragos Tatulea who is listed as a developer on this. 
I havent heard from any one. 

I am willing to work on this. Let me know if you know any current status regarding this RFE.

And also if this is targeted for inclusion in RHEL 6.2. I don't see this assigned yet..so I am assuming not.

Thanks,
Roopa

Comment 13 Stefan Assmann 2011-12-06 07:53:49 UTC
*** Bug 668712 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.