Bug 655055 - spacecmd -q and --quiet not really quiet
Summary: spacecmd -q and --quiet not really quiet
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: spacecmd
Version: el5
Hardware: Unspecified
OS: Linux
low
low
Target Milestone: ---
Assignee: Aron Parsons
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-19 14:13 UTC by Luc de Louw
Modified: 2016-01-04 05:14 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-11-22 15:05:48 UTC
Type: ---


Attachments (Terms of Use)

Description Luc de Louw 2010-11-19 14:13:49 UTC
Description of problem:
When using spacecmd for scripting, the -q switch should suppress additional output, only errors. This works fine unless the cache needs to be rebuilt, the switch seems to be ignored. The result is that the  script calling spacecmd fails. 

Version-Release number of selected component (if applicable):
spacecmd-0.5.4-1.el5

How reproducible:
Always

Steps to Reproduce:
1. rf -rf ~/.spacecmd
2. spacecmd -q -s sat.expample.com -u user -p password system_list
  
Actual results:
^M^M** Generating system cache **^M                             ^Msystem1
system2
system3
...

Expected results:
system1
system2
system3

Additional info:

Comment 1 Miroslav Suchý 2010-11-22 12:56:05 UTC
Giving to Aron.

Comment 2 Aron Parsons 2010-11-22 15:05:48 UTC
Fixed in commit 372c89d225acfbd3306e47ecda36eca319aaf6d9.  This should be included when the next version is pushed to EPEL.


Note You need to log in before you can comment on or make changes to this bug.