Bug 655057 - Exception running pulpd init
Summary: Exception running pulpd init
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Pulp
Classification: Retired
Component: z_other
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Jason Connor
QA Contact: Preethi Thomas
URL:
Whiteboard:
: 658193 (view as bug list)
Depends On:
Blocks: verified-to-close
TreeView+ depends on / blocked
 
Reported: 2010-11-19 14:20 UTC by Jay Dobies
Modified: 2014-03-31 01:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-17 16:52:23 UTC


Attachments (Terms of Use)

Description Jay Dobies 2010-11-19 14:20:04 UTC
It's actually related to the fifo stuff:

[root@fedora-14-64 ~]# service pulpd init
Starting mongod:                                           [  OK  ]
service no crontab for root
pulpdatabase migration to version 1 complete
dException in thread Thread-1 (most likely raised during interpreter shutdown):
Traceback (most recent call last):
  File "/usr/lib64/python2.7/threading.py", line 530, in __bootstrap_inner
  File "/usr/lib64/python2.7/threading.py", line 483, in run
  File "/usr/lib/python2.7/site-packages/pulp/server/tasking/queue/fifo.py", line 83, in _dispatch
<type 'exceptions.AttributeError'>: 'NoneType' object has no attribute 'critical'


I'm not sure we actually use the tasking stuff for pulp-migrate, so I'm a little unsure why we're seeing this. I know we've largely just ignored this in the past, but it looks bad if the init fails and we're just saying "Ignore that."

Comment 1 Jay Dobies 2010-12-01 16:59:38 UTC
*** Bug 658193 has been marked as a duplicate of this bug. ***

Comment 2 Jeff Ortel 2011-01-05 20:21:34 UTC
I think I fixed this while doing the RHEL 5 port by replacing:
  thread.daemon = True
with:
  thread.setDaemon(True).

Are we still seeing this?

Comment 3 Jay Dobies 2011-01-26 20:52:23 UTC
This should no longer be an issue, moving to ON_QA to verify.

Comment 4 Preethi Thomas 2011-01-31 15:02:28 UTC
[root@preethi ~]# rpm -q pulp
pulp-0.0.132-1.fc14.noarch

[root@preethi ~]# service pulp-server init
data model in use matches the current version
database migration to version 1 complete

Comment 5 Preethi Thomas 2011-02-17 16:52:23 UTC
Closing with community release 

pulp-0.0.139-1.fc14.noarch


Note You need to log in before you can comment on or make changes to this bug.