Bug 6551 - Anaconda with RHEA-1999:045 updates doesn't find my Linux partitions for upgrade
Anaconda with RHEA-1999:045 updates doesn't find my Linux partitions for upgrade
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-10-30 21:43 EDT by Matthew Campbell
Modified: 2015-01-07 18:39 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-11-30 10:33:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matthew Campbell 1999-10-30 21:43:21 EDT
I downloaded the boot and updates disks for the RH 6.1 installer, booted with these disks, and chose to upgrade my existing system.  The installer said that I have no Linux partitions and would let me go no further.  Here is how my partitions are set up:

/dev/hda1: FAT16
/dev/hda2: Win95 Extended
/dev/hda5: Win95 FAT32
/dev/hda6: Linux (/boot)
/dev/hda7: Linux (/)
/dev/hda8: Linux swap

I'm not sure how I got the extended partition.  It might have happened when I shrunk the FAT32 parition with PartitionMagic, before installing Red Hat 6.0.  Anyway, my guess is that the installer can't find my Linux partition because it's in an extended partition.
Comment 1 Jay Turner 1999-11-30 10:33:59 EST
My guess is that your extended partition is of type "f" and this is why you are
having problems.  There is a known bug in the installer which prevents it from
seeing into type "f" partitions.  The workaround is to change the partition from
type "f" to type "5" for the duration of the upgrade and then change it back.

The other option is that you can wait until we release the next round of updates
(should not be too long) which will fix this problem.

Please reopen is this is not the problem you are seeing and we will collect more
information from you.

Note You need to log in before you can comment on or make changes to this bug.